0

I have created a custom list with 3 columns, when I add a edit an item of this list I can see created by and modified by details at the end of the form. I want to display just modified by value at some other place in the same form. I am able to display modified date using formula [Modified], but not able to get modified by. Please help. Thanks.

2
  • Internal name of field Modified By is Editor. Did you try to use [Editor] in your formula? (since [Modified] is working) May 29, 2012 at 12:06
  • Does not work :(
    – NotesArt
    May 29, 2012 at 15:12

2 Answers 2

2

I had the same problem you did with the "Modified By" (@Editor) field not showing up on my customized edit form. Following the example from this post, I was able to get the "Modified By" value to display on my edit form by adding the following markup:

<SharePoint:CreatedModifiedInfo ControlMode="Display" runat="server">
    <CustomTemplate>
        <SharePoint:FieldValue FieldName="Editor" runat="server" ControlMode="Display" DisableInputFieldLabel="true"/>
    </CustomTemplate>
</SharePoint:CreatedModifiedInfo>
4
  • I am sorry, but i could not find related to my problem in this article, could you please point it out. Tried <xsl:value-of select="@Modified_x0020_By"/> but did not work. :(
    – NotesArt
    May 29, 2012 at 15:19
  • You are correct. I was testing this against a document library and not a custom list. I have it working now and will edit this answer. May 29, 2012 at 23:28
  • Hi Danny, I have a new requirement where I have to show item creator's name instead of modifier, I have tried to replace Editor with Creator but did not work. Please help.
    – NotesArt
    Jun 7, 2012 at 3:59
  • 1
    Worked with Author. :)
    – NotesArt
    Jun 7, 2012 at 4:02
1

In the ribbon click on the tab "List" > "Modify View"

Then you need to check this option "Modified By" field and save the view. Please refer to the sample view screen below enter image description here

1
  • I can display it in view..but i need it on the form.
    – NotesArt
    May 29, 2012 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.