I have used the sharepoint farm configuration wizard to setup all services under spfarm account and everything works fine. However I am having trouble with Searching for people. Here is the link I have followed: http://www.dotnetfunda.com/articles/article1259-enterprise-people-search-in-sharepoint-2010.aspx

Although I have run a successful User Profile Synchronization, I get the following error while checking the crawl log:



What am I missing?


Two things, the start address for Profiles should be sps3://mysitehost. The permissions on the User Profile Service for the default crawl account has to be allowed to "Retrieve People Data for Search Crawlers". Go to Central Administration | Application Management | Manage Service Applications. Select the User Profile Service Application (don't click the link just select the app). Choose Administrators from the ribbon. Add the Crawl Account and check "Retrieve People Data for Search Crawlers.

Rerun the crawl. M

  • I have already given the crawl account "Retrieve People Data for Search Crawlers" permission. Right now I have it set as "sps3://servername" (which was added by default). I am not sure what you mean by MySiteHost. Is ther a way for me to find this? – user7400 May 25 '12 at 12:23
  • If you are referring to the web application hosting my sites, well I dont have my sites configured yet. – user7400 May 25 '12 at 15:40
  • Was giving the wrong account "Retrieve People Data for Search Crawlers" access! Got it working. Thanks all. – user7400 May 25 '12 at 18:38
  • You need a properly functioning My Site Host for this to work. Otherwise there is not destination for the search results. The SPS3 (or SPS3S for ssl) tell the crawler it is the "people protocol". It actually does not matter what web app you crawl as long as the UPSA is set up correctly and permissions are sorted. Glad you got it working. – Matthew McDermott Feb 13 '18 at 13:34

Add a brand new crawl job and do a full crawl.

  • Oh Im past that. I have tried a new content source with "sps3://servername", a new crawl job and a full crawl a couple of times. The same error though. – user7400 May 24 '12 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.