When trying to access a site on a mobile device. I am getting Object Reference not set to an instance of an object. What in particular would cause this problem. Could I have accidentally removed an item or hidden a control in the new masterpage? This is for a SharePoint Foundation site.

Mobile View Error

I did some further testing and have determined that if I create a new sub site it works fine. If I change the root site back to the default master page I get the same error.

Interestingly enough I did this search "_layouts/mobile/mblwiki.aspx error" and got back a lot of sites with the same issue. Talk about an easy way to find internet sites built on SharePoint that have been customized.


Does it work in computer browsers?

If you are worried about missing sharepoint controls in your masterpage, check that all the controls mentioned in this article are present. (Look under section Required Content Placeholders)

If they are present in your masterpage, check for custom controls. Insert some kind of logging in your custom controls.

Last resort will be to check the site's web.config file for missing parts. Someone might have deleted something in the web.config which is necessary for the mobile display of your site, in case you use SharePoint Mobile to display your SharePoint sites on mobile devices.

I can recommend reading this article to avoid SharePoint's mobile redirect, so you fully control the display of your SharePoint site on mobile devices.

  • Works fine in all browsers just not mobile. I did relay that we could just avoid the mobile redirect. I just find it odd that everything else works right except for this one aspect. – Cory May 24 '12 at 11:39
  • I agree. It does seem odd. Have you tried creating a site with nothing but pure default SP2010 and access that via a mobile device to see if that fails aswell? – user2536 May 24 '12 at 11:53
  • Ill give that a shot this evening. – Cory May 24 '12 at 12:26
  • I've got the same error when accessing a site collection through mobile.The above solution seems to be not working and link is broken.Kindly give a solution for the above issue. – user29509 Jun 10 '14 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.