I have a form library on my site (SharePoint 2010 and InfoPath 2010) and we want any user in our network to be able to submit items, but only a select group of users to be able to edit items once they're submitted.

I figured that would be easy enough, create a permission level for the "catch-all" group to be Add Items, and create an "Editors" group that has Contribute Access (Add and Edit).

The problem is that when the Add-Items users try to submit a form they get a "The form cannot be submitted to the specified SharePoint list or document library. The SharePoint location may be read-only or you may not have permissions to access it" error.

Why would these users be unable to add an item to a list where they have Add Item permissions? It seems that you need to have edit permissions as well! This seems a little counter-productive to me.

  • Wondering if you found a resolution to your problem, as I am encountering the same issue. One site two form libraries, security is the same but one does not allow users to submit.
    – user11554
    Commented Oct 23, 2012 at 21:42
  • I don't think I ever did. And I actually don't work with SharePoint anymore, so I won't be a good resource. Sorry! Commented Oct 25, 2012 at 14:19

3 Answers 3


I would suggest to do the following because even I faced similar pemrission issues before during Infopath and List access.

Create a permission level "Generic Add Items". Make sure that "View Application and Layout pages" permission is checked along with Add item , Read , Open versions among the others.

For editors , generic contribute access should work.

If this error persists, then try to this out as well.

Go to "contribute" permission level modification page. In the extreme bottom, you will find a button - Copy permission level. Hit that button and you will be taken to a new permission level creation page but it will have all levels pre selected that is there for contribute level access. Uncheck those that you do not need and ensure that View Application and Layout pages" permission is checked. Save this permission level and apply to the list.

Let us know if the above solves the issue or not.

  • Ok, so I tested this permission level again with a brand new form library and users are able to submit things just fine. But they are unable to submit items to libaries that were created previously. I don't see any difference in the permissions, since they both inherit the permissions. So I don't know why one library works and the other one doesn't! Commented May 30, 2012 at 20:27
  • Can you republish the same Infopath form on the same List once again and check it ?
    – ArkoD
    Commented May 31, 2012 at 9:01
  • Tried that and users are still getting the error that the library may be read only, which it is not. Commented May 31, 2012 at 13:49

I ran into this same problem the other day. I had a submit button on the form that had Add rules and Edit rules behind it. Turns out the Add rules were firing, then the Edit rules were firing by mistake, and the above message was thrown. Full post with fix on my blog.


I have come across this before and found that you have to give edit permission to the list in order for them to submit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.