I just installed fresh install of windows server 2008 R2. Then I installed wss 3.0 64 bit in the server. Install finished sucessfully, i installed standalone version with Windows Internal Database. Then i created a web application, then Top Level Site collection with Team Site Template asssigned my account as Site Collection Admin.

It completed sucessfully, then i went in and made changes in host file to host it from local host. I ran iisreset after that, then went in tried to open the site, it gave me windows authentication.

So now it didnt let me in, then i went to iis and disabled windows auth and enabled basic it finally let me in and can browse the site.

I dont know why is it doing this, any insights would be greatly appreciated.

Thank You

  • guessing you are facing a http 401.1 or 401.2 error ? please check in the iis logs (search for status and substatus).
    – Steve B
    Commented May 23, 2012 at 14:13
  • Hello Steve thank you for you reply, but i dont see any error code in browser or in iis log files. its weird that my authentication works fine in central admin. Commented May 23, 2012 at 14:27
  • I bet your central admin is accessed using http://servername:port, while your app is accessed using a custom host header (http://www.corp.com/). am I right ?
    – Steve B
    Commented May 23, 2012 at 14:31
  • Yeah i am using custom host header abc in port 80 Commented May 23, 2012 at 14:32
  • I'm still believing you have either a 401.1 or 401.2 error in IIS log file.
    – Steve B
    Commented May 23, 2012 at 14:45

1 Answer 1


When you want to use custom host headers with windows authentication, you have to disable loopback check or whitelist the host names.

Follow this Microsoft KB.

I highly advise you to use the second method (white list) on production servers, as the first method shut down a security mechanism.

  • Applying DisableLoopbackCheck worked !!! thank you. Commented May 23, 2012 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.