I am facing a very frustating permission level issue with Sharepoint 2010. First, everything worked as expected up to few days ago.

I have a user on my sharepoint 2010 env (publishing portal) named rjo who is site collection administrator and has also Full Control permission level.

When I execute the Check Permission command from the ribbon I get the following:

Permission levels given to xxxx\rjo

Full Control
Given through the "xxx Owners" group.

The following factors also affect the level of access for xxx\rjo (xxx\rjo)

Manage Permissions
Create and change permission levels on the Web site and assign permissions to users and groups.

Create Subsites
Create subsites such as team sites, Meeting Workspace sites, and Document Workspace sites.

etc.. Seems like all the individual permissions are set to deny.

If I remove the user rjo from the Full Control permission level, all the deny permissions disappear. I have tried creating a brand new permission level with Allow permission on al items but I still get the deny when I check the permissions. Notice that this happens for all the users.

Does anyone experienced a similar issue? I suspect some kind of Windows update to have messed up the permissions but I cannot find a way to get proper permissions to my users.

2 Answers 2



I had to remove all the permission assignments in "Manage Permission Policy Levels" and recreated them in order to remove the deny permission that were applied.

See full details at http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/ad8f9591-be8a-4664-bbf7-e39bca58101e

  • 3
    While this may answer the question, we prefer inclusion of the essential parts of the answer here, and to provide the link for reference. Please could you expand your answer? See answer for general guidelines.
    – SPDoctor
    Commented May 22, 2012 at 9:31
  • And after making all necessary information available, you should mark your answer as answer. Commented Jun 24, 2012 at 11:38

I had a similiar situation. One site collection in a web application was displaying a similiar output for all users in the Site Owners group. Additionally other functions on ribbon were greyed out or missing. Further investigation revealed that users were also not able to add content to site. The Add button was missing.

Eventually determined that the Site Collection was locked as Read-only. Set to Not Locked.

Central Admin > Manage Web Applications > Configure Quotas and Locks change web app and site collection as needed. Change from 'Read-only' to 'Not Locked'

See also: http://neelb.wordpress.com/2012/01/18/additions-to-this-web-site-have-been-blocked-sp2010/

  • This can sometimes happen when something like a backup fails. Had it happen this morning in fact.
    – jpollar
    Commented Feb 11, 2019 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.