I have issue during deployment. It throws:

Failed to load reciever assembly

I tried to GAC that assembly, also microsoft.office.sharepoint.clientextensions.dll and Microsoft.Office.Server.dll are in the GAC. My feature looks like this:

<Feature Id="09a18ff3-60d7-40bc-b5cf-457a7982ce1c" 

This is the error:

Error occurred in deployment step 'Add Solution': Failed to load receiver assembly "FeatureBuilder" for feature "Ace.EH.Web_MainFeature" (ID: 09a18ff3-60d7-40bc-b5cf-457a7982ce1c).: System.IO.FileNotFoundException: Could not load file or assembly 'FeatureBuilder' or one of its dependencies. The system cannot find the file specified.
File name: 'FeatureBuilder'
   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].'

Any ideas?

Thanks in advance.

  • Could you please paste the code and more error information? May 16, 2012 at 9:53
  • Post was edited to contain more details...
    – Peter P
    May 16, 2012 at 10:58
  • Is this the first feature youre attempting to deploy? Have you deployed others successfully? Could you confirm the feature is in the template folder of the 12 hive?
    – 1c1cle
    May 16, 2012 at 13:10
  • This feature wasn't made by me ... but it was working, until I hang FeatureReciever ... returns error: Expression must evaluate to a node-set ... I tried to erase FeatureActivated() body but still same error => problem is on the way how I hang this event handler ... I'm quite confused where should I define eventhandler ... in xml? or where? ... and yeah this is my first contact with SharePoint feature ... =)
    – Peter P
    May 16, 2012 at 13:41

2 Answers 2


The ReceiverAssembly should be the Fullname of the assembly

FeatureBuilder, Version=, Culture=neutral, PublicKeyToken=xxxxxxxxxxxxxxxx

If developing using SharePoint templages in Visual Studio 2010 use $SharePoint.Project.AssemblyFullName$

  • great, it helps, but now new problem occurs: Expression must evaluate to a node-set...'myModification.Path = "configuration/AplikaceRoly/"; myModification.Name = "add[@key='Sth'][@value='Eth']"; myModification.Sequence = 0; myModification.Owner = "NESS"; myModification.Type = SPWebConfigModification.SPWebConfigModificationType.EnsureChildNode; myModification.Value = "<add key='sth' value='Sth'/>"service.WebConfigModifications.Add(myModification);'
    – Peter P
    May 16, 2012 at 11:57
  • any idea why? that that xpath is correct
    – Peter P
    May 16, 2012 at 12:00
  • Try removing the trailing / in Path and I'd also remove [@value='Eth'] from Name May 16, 2012 at 12:08
  • Nope, still the same issue ... but I'm pretty not sure whether is this part of code called ...I'm quite lost in SharePoint =) I see SharePoint features 1st time ... I tried to debug it but without success ... btw. I bind feature reciever in feature.xml and also in feature file ... I guess it should be in related xml but somebody put all feature properties into SharePoint file ... so ... I'm not sure whether this error is related to event activating features ...
    – Peter P
    May 16, 2012 at 12:20

Use the -Force option with -globalassemblycache deployment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.