What is best and easiest way to uninstall WSS 3.0 from your server. I simply tried Remove option from WSS setup wizard but it does not uninstall all content. like

1> Site created (they were still there in virtual Directories)

2> Database

3> Dlls from GAC

4> Custom controls under Templates->ControlTemplates

So what i did is just removed Databse (admin,configuration and WSS_Content) but when i tried to reinstall WSS it gave an error "Failed To Connect Content Database".

Do any one have any idea why this is happening? SQL services are already running and i am able to access sql server through window credentials

4 Answers 4


First of all when removing SharePoint (any version) the only account that can do this successfully is the same account that installed it.

The uninstaller does not remove any content created by SharePoint, only the files installed during the setup. Just like removing Office does not remove all your documents.


WSS 3.0 makes use of Windows Internal Database, which cannot be removed using Add/Remove programs options.

Please refer the below Microsoft KB Link to remove it manually:


Additional Notes: If you uninstall Windows SharePoint Services 3.0, and then later install Windows SharePoint Services 3.0 on the same computer, the Setup program could fail when creating the configuration database causing the entire installation process to fail. You can prevent this failure by either deleting all the existing Windows SharePoint Services 3.0 databases on the computer or by creating a new configuration database. You can create a new configuration database by running the following command:

psconfig -cmd configdb -create -database <uniquename>

Hope this helps.

  • For the record: not all WSS 3.0 installations use the Windows internal databases. It depends on how you set it up. Commented Jun 22, 2010 at 10:15

I have been having a lot of trouble installing WSS 3.0 on windows server 2008, usign SQL 2008.

I have found often the solution where it asks to create the db usign the psconfig command line but without luck.

I the registry, the server role was WFE and when I changed it to APPLICATION, it is worst. The setup freezes.

I first made a mistake, installing wss as a standalone.... do you know any other reg key that might makes the connection to sql fails ? It is weird since the setup creates 2 bd (config and admin content) and then cannot connects to it.

I have the same error when trying to connect to an existing farm. It's saying that sharepoint serivces are not initialized.

Thanks for any input.

  • I don't whether it would work for 2008 server but please try following steps. >run setup of wss. >choose uninstall and uninstall it completely >Manually delete DB (Sharepoint_AdminContent_GUID,Sharepoint_Config,WSS_Content) >Delete all files under feature folder(if any because all of them already deleted during unistallation process) >Then please try to reinstall wss and choose advance installation and then u can set farm. >At that step if it prompts any error of 'failed to connect config database' then please try with changing server role to application.
    – Anonymous
    Commented Jul 7, 2010 at 13:22

Thanks Wictor & kamleshrao

Just one more thing i want to add here is the resolution of error.

Just change Registry Key for server role (HKLM/Software/Microsoft/Shared Tools/Web Server Extensions/12.0/WSS/ServerRole) is set incorrectly. It was set to SINGLESERVER.

--Please backup your registry settings before making any change in it----

I changed ServerRole’s value from SINGLESERVER to APPLICATION and it worked.

for more detail please refer Link

But i couldn't figure out what is logic behind it.How and when it's changed to SINGLESERVER during installation/un-installation and why changing it to 'Application' worked?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.