after disaster recovery I am not able to upload new documents to the libraries; I always get access denied despite I am a farm admin.

What I did:

  • Installed Sharepoint with a new administration DB
  • Created Web Applications as they were before
  • Attached original content DB to Web application
  • Configured User Profile Synchronization

It seems to me that in the original Content DB there are user rights which do not exist anymore in the new administration DB.

Is there a way to "reset" all the user permissions or to repair them?



Being a Farm admin doesn't give you any rights to Site Collections.

But it enables you to give yourselves any rights. The two main options are:

  • Central Admin | Application Management | Change site collection administrators
  • Central Admin | Manage web Applications | User Policy (in ribbon)
|improve this answer|||||
  • Thanks for your response. I was already site collection administrator and I also have the necessary rights in the "User Policy" but still the same problem. I tried also to create a new library in an existing site but again "access denied". If I create a new site and in there a library then it works. There must be something broken with the user rights... – Manfred Ramoser May 7 '12 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.