4

I am unable to use the STSADM command. When i try to use it, it shows me access denied.

I am the admin of my system, but still I am getting access denied.

9

Are you running Server 2008? If so, you need to open the command prompt using the "Run as Administrator" option.

  • 1
    User Access Control will prevent you from running commands unless you do the "Run As" that Mark suggested. – Mike Oryszak Jun 17 '10 at 19:12
0

Add your user account to the Administrators group on the Local Machine. Make sure the BUILTIN\Administrators is in the Farm Administration group.

Central Administration -> Operations -> Update farm administrator's group

  • yeah i have been added to admin list.still same "access denied" – Anonymous Jun 17 '10 at 18:56
0

Are you logged in as a local administrator of the system? Also, you must be logged in to the SharePoint server via a remote desktop or local connection; you cannot "remotely" administer a SharePoint farm with stsadm.

  • yes i have been logged in as administrator.But i m remotely accessing the PC.Is this an issue? – Anonymous Jun 17 '10 at 19:02
  • As long as you log in remotely with an account that is a member of the Administrators group on the system, you should be fine (as in, issue isn't with remote desktop connection). – James Love Jun 17 '10 at 20:01
0

Check the Folder where the backup file will store and should not readonly. if yes uncheck from folder properte and try again. its working for me. Thank you, Eugine

  • Backup file? How does your answer relate to the question about running STSADM? Perhaps you need to add more details to your answer. – Phil Greer Aug 6 '14 at 20:21
0

Start the cmd prompt with elevated privileges or you'll get access denied ("run as admin")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy