I have a closed term set in my MMS which is linked to a content type in a document library, I uploaded a document into the library and accidentally set the value on that column. When I try to remove that value and leave it blank, SharePoint resets the value of that field to the initially selected value however I need it to be blank. I tried to download a copy of the document, go into the meta data in Excel and remove everything and then saved the document under a different name. However when I re-uploaded this new document it automatically sets the value back.

No matter what I do, I can't blank that column for the selected document. Do I need to have a blank value in my term set or am I missing a setting? I have been through the library settings and content type settings but can't seem to see any options to allow null values.

migrated from stackoverflow.com May 3 '12 at 13:51

This question came from our site for professional and enthusiast programmers.

  • I tried it with a word-file and let Windows7 take away all possible personal data: -> rightclick properties -> Details -> "Remove Properties and Personal Information" -> "Create a copy with all possible properties removed". How to you access to your content type? SP Designer? – Shegit Brahm May 2 '12 at 10:05
  • Should be able to hit it via the front end. I tried what you listed above with the documents in the library but it just re-adds the meta data to the new document, which is odd. It's not really a viable solution either, as we have over 1300 users! – Strutt Livingstone May 2 '12 at 11:06
  • Have you ever figured this one out? I'm having exactltly the same issue. On top of things, it lets me blank out one of the columns managed by a term set, but not the others! p.s. sorry, i didn't mean to post it as an answer, because it isn't. – user9429 Jul 11 '12 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.