My DBA has configured our SharePoint SQL instance for file streaming, and verified all of the settings are correct. I have been following Todd Klindts post on configuring RBS, and everything seems fine until i get to enabling RBS.


The RBS client was downloaded from the Microsoft SQL Server 2008R2 feature pack site http://www.microsoft.com/en-us/download/details.aspx?id=16978

The install command for the RBS client

msiexec /qn /lvx* rbs_install_log.txt /i RBS.msi TRUSTSERVERCERTIFICATE=true      
FILEGROUP=PRIMARY DBNAME=”WSS_Content_Blob” DBINSTANCE=”9904\sharepoint”  

The command to enable RBS

PS C:\Users\white2> $cdb = Get-SPContentDatabase wss_content_blob
PS C:\Users\white2> $rbss = $cdb.RemoteBlobStorageSettings
PS C:\Users\white2> $rbss.Installed()
PS C:\Users\white2> $rbss.Enable()
Exception calling "Enable" with "0" argument(s): "SQL remote blob storage must
be installed on each web front end server and on the content database before it
may be used."
At line:1 char:13
+ $rbss.Enable <<<< ()
+ CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
+ FullyQualifiedErrorId : DotNetMethodException

Any help would be great

thanks, Jason

  • Did you install the RBS.msi on all SharePoint servers in the farm? May 2, 2012 at 21:20
  • there is only one SharePoint server in the farm. The SQL server is on a different VM
    – Jason
    May 2, 2012 at 21:23
  • I have exactly the same problem. The architecture is one stand-alone server, but I receive exactly the same error :-( How can I solve it, please? Thanks.
    – user8268
    May 9, 2012 at 12:18

2 Answers 2


I have discovered that running the msiexec via command prompt didn't work. I double clicked on it and ran through the wizard, worked great after that!

  • Running the wizard did help resolve our original issue. However we did experience a new set of issues when adding additional servers. The cause was a set of group policies changing various settings on the servers themselves. Due to group policies being enforced out of our control, we had to abandon using RBS.
    – Jason
    Nov 21, 2012 at 17:29

If you experienced this problem check:

  • all SQL servers in farm have installed latest SQL Server service pack
  • run rbs.msi through administrator command line without parameters and install by GUI
  • restart server where you run $rbs.Enable()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.