When i try to add a wiki site to my main site, i get an page that says "Error - An Unexpected error has occurred - Troubleshoot issue...". This isn't a particularly helpful error message and i'm slighlty stuch as to how to progress. Has anyone else had this issue, if so how did you solve it?

EDIT --- Thanks @Wictor, i took your advice and hunted through the ULS File, and found four lines that had "Failed" in them

06/18/2010 09:33:00.39  w3wp.exe (0x10AC)   0x0588  
SharePoint Foundation   General 8l36    High    
Failed toactivate site-scoped features 
for template 'ENTERWIKI#0' in site 'http://development-sql/Wiki'.   

06/18/2010 09:33:00.39  w3wp.exe (0x10AC)   0x0588  
SharePoint Foundation   Fields bn3x High    
Failed to activate web features when provisioning site at 
url "http://development-sql/Wiki" with site definition "ENTERWIKI#0".

06/18/2010 09:33:00.39  w3wp.exe (0x10AC)   0x0588  
SharePoint Foundation      General  72h9    High    
Failed to apply template "ENTERWIKI#0" to web at URL "http://development-sql/Wiki". 

06/18/2010 09:33:00.39  w3wp.exe (0x10AC)   0x0588  
SharePoint Foundation     General 72k2  High    
Failed to apply template "ENTERWIKI#0" to web at URL "http://development-sql/Wiki",
error Specified argument was out of the range of valid values.  
Parameter name: Content type not found 
(Id: '0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF39004C1F8B46085B4D22B1CDC3DE08CFFB9C'). 
0x1371a3b0  c871997d-47ca-42ab-9566-4bbb48ee401c

Is this enough info to find the issue?


  • Thanks man, I got the same issue for wiki page home page site feature and your formula worked.
    – user13553
    Dec 11, 2012 at 11:27

5 Answers 5


When getting "An unexpected error has occurred" you should check the ULS logs in SharePoint.

The error page will (in SharePoint 2010) contain a correlation id (a guid) which is unique for the particular request and error. This correlation id is also used in the ULS logs. You can find the ULS logs in the {SharePoint Root}\LOGS. Search for the correlation id in that file and show us the error - and we can most certainly help you out.

Tip: you can run this PowerShell command to get all the details about the error also (just replace the guid in this sample with your own):

Get-SPLogEvent |
Where{$_.Correlation -eq "a53ba71b-4231-4222-ac7e-4535dcf0c534"} |
Format-Table Category, Message -Autosize

I used powershell to run the following:

Disable-SPFeature -Identity a942a218-fa43-4d11-9d85-c01e3e3a37cb -URL http://sitecollection

Followed by:

Enable-SPFeature -Identity a942a218-fa43-4d11-9d85-c01e3e3a37cb -URL http://sitecollection

This worked for me. I guess something had become corrupt with the feature or the layouts involved. Refreshing the feature like this allowed me to create a Wiki site without the content type error.



Found your article and thought this might be of value to people looking. The feature was enabled for me but when I clicked on the content type from within the site administration I got errors (similar to those that drove me to this site).

I ran:

disable-spfeature -Identity a942a218-fa43-4d11-9d85-c01e3e3a37cb -Url http://mysite


enable-spfeature -Identity a942a218-fa43-4d11-9d85-c01e3e3a37cb -Url http://mysite

Content type now worked and I could deploy the Enterprise Wiki site without issue (after 8 hours of digging). Your article helped.

  • Hello, I'm afraid Stack Exchange isn't like a forum, in that the answers are not shown in chronological order. This means it isn't obvious whose article you're referring to...
    – Stu Pegg
    Sep 28, 2011 at 7:24

Hmmm... Try to run the following PS cmd:

get-spfeature -Site http://development-sql

Then check if you find the feature called EnterpriseWikiLayouts

If it is not found, try to enable the feature like this:

Enable-SPFeature -Identity a942a218-fa43-4d11-9d85-c01e3e3a37cb 
    -Url http:://development-sql

I guess that feature is missing...

  • Thanks @Wictor, but i cant get your commands to work. I open Windows PowerShell and copied and pasted each command seperately and got the errors. The Get command gave me: "The term 'get' is not recognized as the name of a cmdlet, function, script file, or operable program." and the 'Enable' command gave me the same error, but replace 'get' with 'Enable'. Any Ideas why?
    – Anonymous
    Jun 18, 2010 at 13:36
  • Use the commmand add-pssnapin microsoft.sharepoint.powershell to load the SP cmdlets Jun 18, 2010 at 18:04

The solution is here, under my post as Sambolini:

MSDN: Cannot create Enterprise Wiki site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.