3

I have an infopath 2010 form that is defaulting to check the first item in the list. I'm needing all items to be 'unchecked' by default. I've changed the default value in both the sharepoint list settings, and in the infopath template to be blank but it still checks the first item by default. Any reason why this happens? Is there a way around it?

4

This behavior is very frustrating, but there is a solution. They just bury it pretty deep in the settings.

  1. In InfoPath Designer 2010, click on File->Form Options (from the middle column).
  2. Then from the "Category" list box, select "Advanced".
  3. Then click the "Edit Default Values..." button.
  4. Expand "dataFields" down until you find your checkbox field.
  5. Then uncheck the box next to the field.
  6. "OK" your way back out.
  7. Save and republish your form.
| improve this answer | |
  • Do not uncheck but delete the default value from input when you select the field. So you somehow directed me to the right solution. – luccio Dec 3 '18 at 14:15
1
  1. In InfoPath Designer 2013, click on File
  2. Form Options (from the middle column).
  3. Then from the "Category" list box, select "Advanced".
  4. Then click the "Edit Default Values then Expand "dataFields" down until you find your checkbox field.
  5. Then select the required field then you can find the related dropdown below with the default value.
  6. Remove the default value from the dropdown
  7. Save and republish your form.
| improve this answer | |
0

You can use an action rule to set any value to any field in the form. Check for the tab DATA -> Form Load and play with the rules there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.