I'd really like to prepare development environment for Sharepoint 2010. This is what I did:

  1. I installed Windows 7 x64
  2. I installed VMWare Workstation
  3. Created a VM domain controller based on Windows Server 2008 R2 Server Core
  4. run the VM and joined my Windows 7 machine to that domain
  5. Installed SQL Server 2008 R2 on Wind7 machine
  6. Followed instructions http://msdn.microsoft.com/en-us/library/ee554869%28office.14%29.aspx and installed these:
    1. WCF Hotfix for Microsoft Windows (KB971831)
    2. ADO.NET Data Services Update for .NET Framework 3.5 SP1
    3. Changed setup as explained on the web page
    4. Filter pack (as prerequisite in setup folder)
    5. Microsoft Sync Framework
    6. SQL Server Native Client (it was rejected because of a newer version being on the system already)
    7. Windows Identity Foundation (Windows6.1-KB974405-x64.msu)
    8. Enabled all roles indicated in the list (IIS and WCF)
    9. Installed Sharepoint Foundation 2010
  7. didn't run the product configuration wizard (yet)
  8. created two additional domain user accounts without any particular rights:
    • SPF_DATABASE for database credentials
    • SPF_ADMIN for farm credentials
  9. Added domain administrator in SQL Server 2008 R2 with sysadmin rights
  10. started Sharepoint Powershell as domain administrator (so I have rights to access domain accounts)
  11. I didn't install SQL Server 2008 KB 970315 x64, because I'm running R2 version - as I understand this is SQL Server 2008 SP2
  12. Enabled named pipes on SQL Server 2008 R2
  13. run New-SPConfigurationDatabase in previously opened powershell using this command:

    New-SPConfigurationDatabase -DatabaseName "Sharepoint2010Config" -DatabaseServer "developer.mydomain.pri" -AdministrationContentDatabaseName "Sharepoint2010Admin" -DatabaseCredentials (Get-Credential) -Passphrase (ConvertTo-SecureString "%h4r3p0int" -AsPlainText -Force)

  14. When I run it, I'm prompted for database credentials and I enter mydomain\SPF_DATABASE and password

  15. I'm also prompted for farm credentials and I enter mydomain\SPF_ADMIN with password

Then it runs for a few seconds and fails with this message:

New-SPConfigurationDatabase : Cannot connect to database master at SQL server a
t developer.mydomain.pri. The database might not exist, or the current user does
not have permission to connect to it.
At line:1 char:28
+ New-SPConfigurationDatabase <<<<  -DatabaseName "Sharepoint2010Config" -Datab
aseServer "developer.mydomain.pri" -AdministrationContentDatabaseName "Sharepoint
2010Admin" -DatabaseCredentials (Get-Credential) -Passphrase (ConvertTo-SecureS
tring "%h4r3p0int" -AsPlainText -Force)
    + CategoryInfo          : InvalidData: (Microsoft.Share...urationDatabase:
      SPCmdletNewSPConfigurationDatabase) [New-SPConfigurationDatabase],
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.

What am I missing? Is there something else I should configure?

Additional info

I've also tried disabling firewall, antivirus and UAC but with no luck.

  • Have you tried enclosing the Get-Credential and Convert-ToSecureString in object parentheses $(Get-Credential)? Jul 28, 2010 at 10:52
  • Have you tried connecting to SQL using SPF_DATABASE, SPF_ADMIN credentials and SQL Management Studio? Have you tried explicitly adding the corresponding logins to the database roles? Aug 25, 2010 at 20:25
  • I had the same problem and so I gave up (after extensive time wasting). If I can say so the worse waste of time was the SPEasyInstall crap from MS). Now I'm running in a virtual machine on a server. This means having VS installed too. I wouldn't recommend this route unless you got at least 6GB's of ram (4GB's for the guest) - even 6GB's isn't much. 12GB's would be a whole lot better.
    – user879
    Dec 7, 2010 at 18:34
  • Did anyone find a solution to this?? I am hitting this and pulling my hair out of my head. Tried everything but still keeps on throwing this.
    – Spaceghost
    Jul 6, 2012 at 23:18

5 Answers 5


Typically when I start, I'm using more than just two accounts. Different services should be on different accounts, and you will want at least one account for the app pools. It is also best practice to use a separate account while running the setup process.

When running the New-SPConfigurationDatabase script, try providing the mydomain\spf_database credentials when prompted. That prompt threw me as well, but it worked when the account I used had access to the sql server.

  • I'm actually using 3 accounts: mydomain\administrator (used to run the New-SPConfig...), mydomain\spf_database (as database account) and mydomain\spf_admin (as farm credentials that will probably be used as application pool account). I tried and manually added mydomain\spf_database to SQL Server as sysadmin (so it has all rights it needs) but it didn't work either... Jun 15, 2010 at 13:57

The account that you are running the cmdlet with must have the dbcreator and securityadmin roles on the SQL Server.

  • It does. It's sysadmin as stated in 9. And I've added it to securityadmin + dbcreator roles as well. No difference. Jun 16, 2010 at 13:28

Enabled named pipes on SQL Server 2008 R2

Why Named Pipes and not TCP/IP?

I never had any problems on W7 using either SP Foundartion or SP Server against SQL 2008 as long as I enabled TCP/IP on the SQL Server. Never tried Named Pipes or Shared Memory though.

As for the Hotfix: You're right, SQL 2008 R2 doesn't require any additional hotfixes.


I had this issue and I have a fix for me.


I had TCP/IP disabled. Enabling that worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.