There are some posts claiming to know how to "hide" the My Site link:

One method is to simply remove permissions for all authenticated users to use social features via Central Administration. I don't like this big bang approach.

The other method (which I prefer) is removing the following from the masterpage:

<SharePoint:DelegateControl ControlId="GlobalSiteLink1" Scope="Farm" runat="server"/>

However I cannot find it in any master page!

In my case I actually have the "My Site" link hidden on a page and I am trying to recover it (i.e. activate the link again): enter image description here

To get the link back I would have to know how to remove it in the first place (or find out how the developer did it) and I don't know how to do that as I tried on a fresh site to remove the link to no avail.

2 Answers 2


Found the answer:

Where do "My site" and "My profiles" links come from?

And there actually even is: Activate or deactivate the SocialRibbonControl farm-level feature (SharePoint Server 2010) (MSDN)

Enable-SPFeature SocialRibbonControl and the My Site link was back. Disable-SPFeature SocialRibbonControl and it was gone. Perfect. Keep in mind that this is a farm wide setting, so changing the master page is definitely better.

  • Good finding. helped me too. Thanks for posting the solution. Commented Nov 22, 2013 at 16:49

If your single purpose is just to hide the MySite the recomanded way is to use Permissions and disable required actions - this will directly impact, and therefore HIDE/SHOW appropiate links. Is all described here http://howtosharepoint.blogspot.com/2010/11/hide-disable-my-site-my-profile-and.html

Basically, you could (and you should, if havent' done so, for better control over these features), create AD Groups where you put people that should get My Sites, or just My Profile pages, or be able to use social features!

Hope this helps, C:\Marius

  • Marius, as you can see in my OP I did mention that one can use permissions to hide/show the link. In my particular case and in another case (as seen in the comment) the social farm level feature was simply deactivated. Permissions would have never solved that ;-)
    – Dennis G
    Commented Nov 23, 2013 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.