*Tears hair out*

I've been following this - http://msdn.microsoft.com/en-us/library/ee554869.aspx walkthrough to set up Sharepoint Server 2010 on my local machine (Windows 7 64-bit). Sharepoint "installs" absolutely fine but the "configuration" program will not run. I get the following error:

System.InvalidOperationException: Stand-alone provisioning has failed because an 
error occurred while enumerating the SharePoint Server products installed on this 

The only "help" I can find is here - http://social.technet.microsoft.com/Forums/en-US/sharepoint2010programming/thread/42239d23-26cd-4571-a4ac-b3bc74f9ad3a/ - but I've already put in and validated a license key so surely that can't be the problem?

I've included full exception details below in case it helps. If anybody could shed light on this I'd be grateful.

Note: I want Sharepoint Server rather than Foundation on my local machine so that it replicates the live environment, obviously. Sharepoint Foundation does install without any problems.

Also note: Any HTTP requests from my machine are routed through a proxy.

HELP! (Thanks).

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: Stand-alone provisioning has failed because an error occurred while enumerating the SharePoint Server products installed on this server.
   at Microsoft.Office.Server.EvaluatorModeProvisioning.OfficeServerProducts.get_OfficeProductList()
   at Microsoft.Office.Server.EvaluatorModeProvisioning.OfficeServerProducts.IsInstalled(OfficeServerProductToProvision product)
   at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioning.GetProvisioner()
   at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioning..ctor(TraceListener listener)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Microsoft.SharePoint.PostSetupConfiguration.ReflectionHelper.InvokeConstructor(String assemblyQualifiedName, Type[] constructorSignature, Object[] constructorParameters)
   at Microsoft.SharePoint.PostSetupConfiguration.TaskCommon.ReflectionHelperInvokeConstructor(String assemblyQualifiedName, Type[] constructorSignature, Object[] constructorParameters, TaskBase task)
   at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.LoadProvisioner()
   at Microsoft.SharePoint.PostSetupConfiguration.WelcomeForm.ShowNextFormForServerRoleSingleServer()
   at Microsoft.SharePoint.PostSetupConfiguration.WelcomeForm.PsconfigBaseFormNextButtonClickedEventHandler(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

EDIT - have tried with a completely fresh install / license and same error. I have Office 2003 on my machine - could this be the issue?

SOLVED As noted in comments under C.Darius answer (accepted) - selecting "Farm" option instead of "Standalone" (as it suggests in the MS article) basically did the trick. Following his suggested steps important though.

EDIT NOT SOLVED. Can now access Central Administration, create a web application and create a site collection - but when I try to access the top level site I get exactly the same error!!!!

SOLVED Uninstalling (manually) SQL Server Compact 3.5 SP2 resolved the issue. For whatever reason, Sharepoint iterates over all installed products looking for errors. It found one there, and this meant no site pages could be accessed! Probably a good reason for it - I'm open to suggestions... :)

3 Answers 3


Make sure you have your DOMAIN ACCOUNTS ready - without this only STANDALONE will be available, meaning that many services (e.g. UPSA) will not be working as they are not provisioned!!! - DO NOT use your LOCAL Administrator to configure the farm as this will be used as the Farm Account later, rather log in with any domain account that will be using further. - These Domain accounts should be in the Local Administrator groups during install and configuration, can be removed afterwards. Also do a REBOOT after changing permissions -very important!! -have at least 1 log in these accounts once, just to make sure the windows .data files are created as SharePoint services are not able to do it.

  1. Make sure you installed all the Prerequisites yourself MANUALLY - very important, as in WIndows 7 it does NOT work

  2. Install SharePoint Server (preferably Slipstreamed with SP1 but if not do it afterwards) - DO NOT RUN Configuration Wizard (check out at the end)

  3. Run Windows Update (preferably you should have started already from SP1 at least!) - there is WCF Update needed for W7.

  4. Install SP1 of SharePoint, any language packs (language packs installation is the same as with SharePoint - you need to unpack 1st using the /extract option, change XML configuratio and then install)

    • FOUNDATION followed by the SERVER.
  5. Install SP1 Foundation + SP1 Language Foundation, then SP1 Server and then SP1 language.

  6. Install June Update + June Refresh update

  7. Install any CUMULATIVE Update - December 2011 - not needed for Foundation and Server separately as CU's are for everything now - including Language Packs.

ONLY NOW you are ready to run configuration Wizard! - I strongly suggest using a PS script for it - more control (drop me a message I have one I can share!)

Hope it helps, C:\Marius

  • Wow thanks. That's a comprehensive guide! I think the problem I will come up against here is the Windows Update / SP1 bits - I have neither available to me because of company policy. Apr 24, 2012 at 14:10
  • It would be very dificult unfortunatelly to get all the proper bits together! Can I suggest using VHD boot to build your own machine just for SharePoint', this way your regular environment stays clean and you have your full playing machine too. Apr 25, 2012 at 13:36
  • I've actually managed to persuade our IT dept to "open up" everything for me - although one question - is SP Service pack available from Windows Update? Apr 25, 2012 at 14:05
  • Dave Coleman maintains a list of all updates and service packs up to Feb 2012 even sharepointedutech.com/2010/09/06/… Apr 25, 2012 at 14:56
  • 1
    All working now! I was actually trying the "standalone" option (as it says in the instructions) but gave up and tried "farm" and it went through with no problems. The steps: 1 - Install pre-reqs, 2 - Install Sp, 3 - Run Windows Update (and install all updates), 4 - Run Sp Products Configuration Wizard... Thanks for your help!! Apr 26, 2012 at 14:30

I was going to suggest there might be some kind of conflict with an office product before you mentioned you had 2003 installed. I have found that once in a server environment I had SharePoint Designer 32 bit installed on a SharePoint x64 WFE server, for a task that required editing a master page I could no longer get at. I was then ready to install x64 SharePoint 2010 and some component of that requred that I remove the 32bit version of any office product from the server prior to commencement. I believe this was during the Prerequisite installer phase.

Out of curiosity has the Prerequisite installer completed successfully>

  • I can't run the prereq as it's Windows 7 - however, I've definitely got all of the prereqs installed, and the correct features enabled. I have got Sharepoint designer installed, and I believe it's 32-bit - will try uninstalling that first and see how that goes... :) Apr 24, 2012 at 13:32

I'll answer it myself then (with the help of a chap call Rock Wang...)


How a corrupted install of SQL Server Compact 3.5 SP2 can bring down an entire Sharepoint site collection is beyond me / a little worrying though... :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.