Yesterday I tried to add the Ajax Control Toolkit to my solution, i first had some problems because I used the version for .NET 4.0, so i replace it and used the version made for .NET 3.5.

I only added this lines :

To add a calendar control to my page. The problem is that now i have a server error Server Error in '/' Application. Runtime Error

And I don't get it to show the stack, i tried modifying the web.config, but it seems that the changes are not changing anything.

Does anyone have any idea ?


EDIT : Even if i take the line i added back i have the same issue, i deleted the ajaxcontroltoolkit.dll of the references, retracted the solution and redeployed it, and i still have the same problem ...

EDIT2 : I just saw where the problem is the tag <%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %> It seems that the assembly is not loading in the GAC ... I can't find it in the assembly folder

  • Have you added it as an additional assembly in your solution? Apr 24, 2012 at 9:24
  • Well the assembly is in the Reference folder of my solution yes Apr 24, 2012 at 9:26
  • That's not enough see answer Apr 24, 2012 at 9:30

1 Answer 1


In your VS2010 solution double click Package.package

In the bottom of the editor switch to the Advanced tab:
enter image description here

This will bring you to a screen where you can add external assemblies to the WSP package to inform SharePoint to put the assembly into GAC

  • Hey, thanks for the tip, So the dll were added to the assembly folder, but i still have the problem. I tried to do a blank page, only with the reference to the dll : <%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %> And i got the same error. So should it be a problem coming from the assembly ? Apr 24, 2012 at 9:47
  • Do you have any <%@ Assembly Name="FULLNAME of ASSEMBLY"%> before the <%@ Register ...>? Apr 24, 2012 at 10:30
  • <%@ Assembly Name="$SharePoint.Project.AssemblyFullName$" %> <%@ Assembly Name="Microsoft.Web.CommandUI, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> That's the only two <%Assembly i have Apr 24, 2012 at 10:56
  • Then the Assembly in your <%@ Register> should be with fullname so .net can load it from GAC Apr 24, 2012 at 11:29
  • I just tried to put this : <%@ Register TagPrefix="asp" Assembly="AjaxControlToolkit, Version=3.5.51116, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e" Namespace="AjaxControlToolkit" %> but it didn't work Apr 24, 2012 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.