I have a few custom workflows created by another developer on my dev sharepoint farm. We recently realized that you can apparently not just migrate these things with the rest of the content in a site/site collection. In order to get them working I was going to create new workflows in production and copy the steps, etc into the new farm. However, the dev farm is giving me the error "Unable to load workflow actions from the server. Please contact your server administrator" as if that person would know. I am the server administrator, and I do not know how to solve that problem. Looking around the web I have seen several suggestions and I have tried all of them that seemed feasible and apply to my situation.

One solution suggested using Fiddler to snoop the HTTP transactions for any missing/broken requests. One such request stood out: I got a 500 error for /_vti_bin/webpartpages.asmx

I then dutifully went to my web browser and successfully opened it there. I have a feeling this is where my problem is but I don't have any issues opening the workflows in production. How can I get this to work?


  • Matt

** UPDATE 10/16/2012 **

Still no luck updating this. I put in a ticket with the Microsoft Partner Network and I think they gave up on it, too. Has anybody else ever experienced this issue?

7 Answers 7


Our issue was the missing feature.xml for the PowerView feature: 14\Template\Features\PowerView\feature.xml on our WFE.

Rather than using Fiddler which didn't seem to help, we discovered the error in our ULS logs (see below).

Working on this missing feature, we then activated the feature on the Root Site collection, but this didn't solve the problem. I then discovered the PowerView\feature.xml was on the Application Server but not on our WFE. So I copied the "PowerView" and "PowerViewStapling" features to the WFE. I could then create a Workflow without an IISReset.

Here's the ULS extract: "FetchLegalWorkflowActions" is probably a good search term (and then work your way back up using the correlation token):

03/06/2013 10:29:52.28  w3wp.exe (0x0864)                           0x08BC  SharePoint Foundation           Logging Correlation Data        xmnv    Medium      Name=Request (POST:http://portal:80/Applications/Site/_vti_bin/webpartpages.asmx)   d4b2ddf0-4ed3-45c9-a5cd-53d0730268c0
03/06/2013 10:29:52.29  w3wp.exe (0x0864)                           0x08BC  SharePoint Foundation           Logging Correlation Data        xmnv    Medium      Site=/  d4b2ddf0-4ed3-45c9-a5cd-53d0730268c0
03/06/2013 10:29:52.29  w3wp.exe (0x0864)                           0x08BC  SharePoint Foundation           General                         8e1f    High        **Failed to find the XML file at location '14\Template\Features\PowerView\feature.xml'**    d4b2ddf0-4ed3-45c9-a5cd-53d0730268c0
03/06/2013 10:29:52.29  w3wp.exe (0x0864)                           0x08BC  SharePoint Foundation           General                         avfx    High        SOAP exception: Microsoft.SharePoint.SPException: Failed to find the XML file at location '14\Template\Features\PowerView\feature.xml'     at Microsoft.SharePoint.SPXmlDocCache.GetGlobalXmlDocument(String pathTemplateRelativeXml, SPFeatureDefinition featdef)     at Microsoft.SharePoint.Administration.SPFarmFeatureDefinitionContext.LoadFileAsXmlDocument(SPFeatureDefinition featdef, String featureRelativePath)     at Microsoft.SharePoint.Administration.SPFeatureDefinition.EnsureGlobalDefinition()     at Microsoft.SharePoint.Administration.SPFeatureDefinition.EnsureElementManifestList()     at **Microsoft.SharePoint.SoapServer.WebPartPagesWebService.GetWorkflowActionsFromFeatureElements(UInt32 currentLcid)     at Microsoft.SharePoint.SoapServer.WebPartPagesWebService.FetchLegalWorkflowActions()**    d4b2ddf0-4ed3-45c9-a5cd-53d0730268c0

The problem here was actually a custom branding solution. I was helped by Microsoft Support on this issue, and we discovered that the branding solution had been applied twice. Once as a Farm-level solution and once as a Site Collection-level solution. There must have been something wrong with the Farm solution because when we removed that one the problems went away. So, let that be a lesson to you all! Check your solutions/features to make sure you don't have anything bogus in there messing you up.


Here's a link to a blog entry I wrote on writing SPD custom workflow actions for 2007 http://blog.ianchivers.com/2011/02/office-sharepoint-designer-2007-custom.html. It might help you identify where your missing something from your live server. Pay particular attention to the .actions file and the web config. Also check out if the assembly was added to the GAC (c:\windows\assembly) folder on the dev box, or it was put into the bin folder.

Hope this helps, Ian.

  • there's no "assembly." the workflows in question were created solely in SharePoint Designer 2010. I also copied the .actions files from one prod to dev and it made no difference. I made a comparison of the web.config files between the two servers and there was not a significant difference between the two.
    – Matt
    Commented Apr 20, 2012 at 13:39

This error can be misleading. I see a lot of responses around the net with this as the solution but in my case this didn't resolve anything.

In fact I have yet to get to the bottom of this but I can tell you a server reboot got me going again. (yes, a good old reboot)

I'm thinking there is a universal issue that caused everything to stop working. Also another indication of the symptoms I had were people weren't able to get to linked files that were uploaded and no one could upload any files.

If or when I figure out what the real problem was that produced this error I will post here.

It's just strange because I didn't do anything to create this issue. I walked into work ready to start my day and people were complaining they weren't able to get to files that were attachments inside of SharePoint list items. While I was fielding these issues I was actually in the middle of troubleshooting a failed workflow (failed restart -trying).

My point is that based on some other issue you could have this same error show up.


some times due to some workflows SharePoint designer may give above error. you can find the custom workflow by going through your site collection --> Galleries --> solutions and deactivate the custom solution. Your SharePoint Designer becomes free of that error.


I downloaded FeatureAdmin2010.exe from codeplex and opened it in one of the WFE servers.

I selected the site which had the erroneous workflow and noticed that it has several missing features.

I removed such features from the SiteCollection and the Site. This solved my issue and I was able to edit the workflows.


Below things resolved my issue:

1) Close Designer.

2) Delete all folders in the following directory in local:

 C:\Users\USER\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache\

3) Delete the files in all folders in this directory in local:

 C:\Users\USER\AppData\Local\Microsoft\WebsiteCache\ don’t delete the folders, just delete the contents of the folders

4) Delete everything within this location. Click the address bar > Paste in:

 %APPDATA%\Microsoft\Web Server Extensions\Cache. Delete everything in this location

5) Restart Designer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.