I can't for the life of me get intellisense working for the Client OM. It seems to work on another box I have tried so I'm wondering if I have found some kind of bug/configuration issue.

I have tried all the methods in the official MSDN post and COB's post with no luck. Visual Studio indicates it is 'Updating JScript Intellisense' but it just doesn't work. I have tried this in a Visual Web Part, Application Page and js file.

My environment is as follows -

  • VS2010 SP1
  • VS2011 Ultimate Beta
  • Resharper

I also have the CKSDev tools installed, CAML.net intellisense and a few other extensions.

I'm wondering if its something to do with me having VS2011 installed. Has anyone else had similar issues? I would really like to get ECMAScript intellisense working as it would be massively handy!



  • Just an update - it works in VS2011 :S
    – Alex Clark
    Apr 19, 2012 at 5:19
  • I don't think its because of VS11. I have also got both installed on my dev machine and the intellisense works well in VS2010 Apr 19, 2012 at 5:27
  • I've just figured it out - its resharper! once I turned off resharper's intellisense it started working :-)
    – Alex Clark
    Apr 19, 2012 at 5:30

2 Answers 2


There could be two issues other than the Re sharper, this has happened with my Dev team as well.

We implemented the following two solutions

Missing Intellisense and Document for VS 2010

Intellisense for ECMA Scripting in VS 2010

Hope this will help you work with the Resharper as well.




Figured it out guys - it's caused by Resharper. Once I turned off the option to use Resharper's intellisense over VS's it started working :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.