1

I have made event receiver which updates a field in a list, that event receiver is running in the subsite but not the the root site. The event receiver is scope = web.

Can there be some issue with that, also I cannot see

SPSecurity.RunWithElevatedPrivileges(delegate()
            {


                EventLog.WriteEntry("Windows SharePoint Services 3", errormsg);

            });

Please suggest, The site is in WSS 3

Thanks

5
  • could you say more about the event handler target (sync/async, *-ing, *-ed, etc.) ? Apr 17, 2012 at 16:59
  • its on ItemAdded
    – RHM
    Apr 17, 2012 at 18:52
  • How have you deployed this? As a feature? Have you activated this in both webs? If you give details on how this was deployed and associated with the structure (list or content type) we'll take it from there.
    – Ciaran
    Apr 17, 2012 at 18:53
  • I deployed it as a feature on both the sites and on both sites the features are activated, on subsite it works but on its parent site it isnt working.
    – RHM
    Apr 18, 2012 at 10:00
  • It is only meant to work on a custom ID column which will be incremented by +1 everytime the new item is added.. that custom ID column is there on both the sites in the list
    – RHM
    Apr 18, 2012 at 10:02

1 Answer 1

1

Download and install Sharepoint Manager http://spm.codeplex.com/releases/view/22762 then browse to your list. See if the event receiver is actually atttached. If not, you have a deployment issue. If yes you have a code issue! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.