I have added a XSLT List view webpart to a sharepoint master using SPD 2010( in PlaceHolderLeftNavBarTop content placeholder ). The datasource for this list view webpart is a Links library. I have customised it to display the URL column. But when I move the cursor over the link item it displays the dropdownlist as shown below.

Similarly I want to disable the sorting on the column header.

Could someone let me know how to achieve this?

enter image description here

1 Answer 1


Currently, You have included "Title (linked to item with edit menu)" in the view of the list. Hence you see the drop down.

Go to the list view and uncheck the column "Title (linked to item with edit menu)". You can use "Title" or "Title (linked to item)" . Then include this column in the data-view.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.