I am trying to deploy a list definition which contains a TaxonomyFieldType, however the managed metadata field that gets deployed is greyed out. This is very frustrating as there are no error messages or other indicators as to what might have gone wrong. I have read on some blogs that this can happen because a special feature with guid 73EF14B1-13A9-416b-A9B5-ECECA2B0604C doesn't get activated by default for blank and custom template sites. So I activated the feature with this command

STSADM -o activatefeature -id 73EF14B1-13A9-416b-A9B5-ECECA2B0604C -url http://<server> -force

However the problem persists. Any ideas?

  • How do you deploy it?
    – Louis
    Commented Apr 13, 2012 at 23:16
  • For now I'm just debugging using Visual Studio. This brings up my list with all other fields functioning as expected, except for the taxonomy (metadata) field.
    – alexp
    Commented Apr 13, 2012 at 23:44

3 Answers 3


TaxonomyFieldType fields are quite complicated to privision:

  1. You need two fields a TaxonomyFieldType and a corresponding Note field
  2. No need to set the SspId to the Id of the TermStore

One guide from Wictor Wilén is here: How to provision SharePoint 2010 Managed Metadata columns


Managed Metadata field depends on Managed Metadata Service Application which should be created\connected in central administration.After the service application is created, you need to connect the Managed Metadata field to the Term set .After these manual steps only the field becomes usable.

You can create a feature receiver to automate the process as mentioned here:



Not sure if you have the answer to your problem programatically, but you can go into list settings where deployed and set these lookup fields by connecting again to the taxonomy tree structure. That should fix the grey issue. The other issue, probably more annoying is to set these fields as required; optional etc...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.