I have a dev server for a SharePoint 2010 Publishing site, with a problem.

When I log into SharePoint as a Site Collection Admin (among other group memberships) and go to the site collection site settings page, then click "People and groups" I'm shown the first group (Group 1, let's call it) and it's memberships (a collection of FBA roles). If I then click a link for a different group the majority of the time the memberships list stays the same as Group 1, even though I know they are different. The URL of the page does show the new MembershipGroupId=2 value correctly, but the breadcrumb of the page shows "my site > Site Settings > People and Groups - Group 1" rather than Group 2.

Occasionally I can click through 2 or 3 groups before the people.aspx page shows the memberships from the previously viewed group, and after that it seems never change the memberships list when I click on different groups. (though if I close down the server, leave it for a while, I can come back and change groups and see correct memberships.. until the issue rises again)

Also, if I try to change the View from "Detail View" to "List View", the page refreshes but still shows the detail view, and the drop-down options for View stays as detail view too.

I have no idea what caused this to happen, or when I started happening, though I have started a new server (Amazon EC2 instanced) based on a backup from a month ago and that works fine. I've tried recreating the major updates I made on the server since that backup was taken, but so far I've not been able to replicate the issue, so not sure my custom code (though my Visual Studio project doesn't deal with groups anyway) is the cause.

So far is doesn't appear to be impacting the operation of the publishing pages aspect of the site, only the system settings area for People and Group, though I did also notice that sometimes if I try to change the master pages for Site Master Page and/or System Master Page, the page refreshes way too quickly and the change didn't take, until I do an IISRESET.

It's almost like the page is being cached somehow. Could that be possible? Has anyone else had this type of issue before and fixed it?

Here's hoping someone can help with this strange issue ;)

(also, having trouble working out appropriate tags for this question, so if anyone has ideas and wants to update them, I'd appreciate that too)


  • update: I cleared cookies, forms data, temporary internet files, etc from IE on my dev server, I can still get the Site Settings page and it claims I'm logged in. However, if I click any links on that page I'm taken to my login form. Definitely seems to be some server based caching thing to my untrained eye.
    – QMKevin
    Apr 13, 2012 at 16:47

1 Answer 1


IIS 7 Output caching! I'd enabled this a while ago to try and improve performance on the public side of the SharePoint side - but apparently the only noticeable effect was that the system pages were cached. Oh well, having turned it off my group memberships are now displaying properly. Lesson learned.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.