I am performing an upgrade from a 2007 environment to a 2010 environment and am having an issue with content types.

In the 2007 environment, there was a custom content type from our codebase in a subweb for a department news article that they didnt want to be used elsewhere. However, the requirements for this have changed and they want this content type used elsewhere.

The content type itself is pretty straightforward, as it inherits from the Page content type. In my new codebase, I have the same content type, but when I go to deploy the project, I get the error:

Error occurred in deployment step "Activate Features". The content type with Id "0xBlah" defined in feature {feature} was found in the current site collection or in a subsite.

I get this error not only with existing content types, but brand new ones aswell.

Upon searching this error, i get conflicting solutions none of which work. To give examples, I have changed the deployment steps of the wsp, attempted to activate through the ui, through powershell (even force doesnt work), restarted the server, retracted then deployed then closed VS only to reopen and try again, etc.

Has anyone successfully corrected this sort of issue?


I had the same issue a few months ago. Try one of the following things:

  • Unbelievable but: Make sure you don't have comments in you xml file (its true at least for custom actions and site column definitions)...
  • For your site columns you are using in your content type, set the attribute Overwrite="TRUE"

Hope one of these helps.

  • Ill give it a try. – John S Apr 13 '12 at 20:57
  • First off, it worked. So thanks :D. Second, what the heck? Comments not allowed? – John S Apr 13 '12 at 21:58
  • Yes, thats really strange. The link to the blog I've posted is from an ex colleague and I ran into the same issue... in the blog post you can see the MS code (via reflector). -> they are looking for an "Id" attribute in every(!) xml node (also comment nodes...) ;-) – marco Apr 14 '12 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.