I have enabled anonymous access from central administration. Now my site is accessible from public facing url but my blog is still not accessible.

Check: wwwqa.nextdocs.com/en-us/blogs.

I also noticed that if i visit blog posts it works fine.

Check: wwwqa.nextdocs.com/en-us/blogs/Lists/Posts/Post.aspx?ID=1

Whats wrong with default.aspx page?

  • Is you default.aspx page checked in? Does it have any web-parts on it? Note that the menu item links to home.aspx which doesn't exist Apr 11, 2012 at 6:16
  • Hi Per, Thanks for reply. Yes my page is checked in and i am using a custom web part which is also deployed. But still it is giving 401. If it is web part problem what/where should i check for the problem? Thanks.
    – Feroze
    Apr 11, 2012 at 6:32
  • I'd start by removing the web part to see if it's the problem. Any code that access anything that anonymous don't have access to will trigger the AccessDenied exception, which by default is caught by SharePoint go give a 401. An option is to debug and step through the code until the exception is thrown. Apr 11, 2012 at 7:05


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.