I was hoping someone could help me out with a little issue I have in regards to a customized masterpage. A bit of background:

I need to revamp our Intranet website upon migration to 2010 so decided to go from scratch. So this means new masterpages, new css's etc.

I am re-creating a publishing template so took a copy of the out of the box 2010 publishing template (dayandnight) and began customizing it. The content type once copied was set to Publishing Template. I removed a few of the left contentplaceholders so I had a complete full page. This worked out fine and saved the new masterpage and made it the default master page for the site. The content type though once saved changed this from Publishing Template to Master Page.

So after doing this I noticed my issue when I created a new page layout. I want the new page layout to inherit the new customized masterpage so I can utilize the full page without the left navigation but unfortunately the new layout somehow still inherits the old publishing template with the left navigation.

So my question is why is it doing this? Is there a step I have missed out on?

Note: I tried to change the content type back to Publishing Template through the MasterPage gallery and had no luck.

Would really appreciate any feedback.

2 Answers 2


Both the v4.master and nightandday.master are compatible with Publishing or Collaboration sites, it is only a matter of being able to activate one or the other. In Collaboration Sites you can simply enable it via SPD (Sharepoint Designer), whereas activating the publishing features would give an application page that enables you to change it.

Now, to your problem, hiding the left navigation menu, that is pretty easy with multiple options, actually you don't need a new master page for it: 1. If you are going for using any OOTB master pages you use an CEWP with some CSS styles to hide the such as body


{ display: none; /hides the content of the panel/ } .s4-ca /this is to reset the whole content area to the left, otherwise you end up with empty space still being kept/ { margin-left: 0px; }

  1. Each custom page layout could re-enable it, or even more, could hide the whole Place Holder, technique you can use in your master page too / don't remove any, but rather move them in a hidden div or placeholder control.

Hope it helps, C:\Marius

  • I have done already this on the team site to remove the View All site content leftpanel. I didnt realise i could do this also on the publishing site too. I will try this, thanks :)
    – Sanchez
    Commented Apr 6, 2012 at 1:16
  • Did it helped fixing your issues? Commented Apr 19, 2012 at 7:28
  • Yes i ended up working it out. Thanks for your help.
    – Sanchez
    Commented May 14, 2012 at 3:09

The OOTB publishing Page layouts are not using the Default Master page of the site, but the Custom Master page of the site.

So you usually want to set both Default and Custom to the same. In "Site Settings | Master Page" they are called "System Master Page" (Default) and "Site Master Page" (Custom)

  • I am fairly certain I have done this step in my testing and it still occurred. I will try it again and report back. Thanks
    – Sanchez
    Commented Apr 6, 2012 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.