2

I want to index only the files with a specific extension "*.las". I know that there are less than 20K of these files and there are a total of over 1 million files in the containing fileshare.

I've used an include rule for the extention "*.las" and an exclude rule for everything located on the host. The assumption was the include would trigger first to catch the desired files and the exclude would keep everything else out. That version didn't index anything.

When I indexed using just the include rule, I still got all 1 million files even though the rule ended with "*.las" and there aren't that many of those files on the share.

I'd provide the string I used for the rule but Markdown is playing games with the slashes.

How to I configure the crawl rules to only crawl one file type for a given host/share?

3

Have you done Full Crawl after setting up the rules?

2

Here is how I addressed the problem.

I created two crawl rules, one to exclude all files and one to include the desired file extension. Put include rule above the exclude rule. That way only the desired files get included and everything else matches the exclude rule.

Example:

Include Rule

file://hostname/sharename/*/*.las

Exclude Rule

file://hostname/sharename/*
  • 1
    Use the "code" button in the text toolbar to format text, code, urls etc. without being mangled in the render. It also makes vital pieces of code such as periods, commas and quotation marks easier to see. – James Love Jun 2 '11 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.