Here's a weird one. We are using Search on an Enterprise install of SP2010. Content source is set to a specific folder in a file share and the search service account has read and execute access to all files and folders in that path. I have scoped the entire content source as well a test scope for just .xls files under the content source. All of the file names of interest have a sales order number in them so that is always my search criteria.

If I search for files with a number of 5xxxx in them which are all under a particular sub-folder, an exact match is made. However, if I search for a number of 4xxxxx, I rarely (if ever) get a correct result and ususally no results. The number exists in the file itself but search completly ignores the filename that has the number in it. For instance, if I search for 413208 I get 0 results. But, if I search for 413122 I get the file name 413208mg_shake%20software_re%20po#%603.xls which is what I was looking for by searhing for the first number. If I search for po#603 the correct result shows up but not 413208!?!

Can anyone give some suggestions as to what might be mixing up the results? The only difference I can see is that the 5xxxx files have the sales order number in the middle of the file name versus the beginning. e.g. FileOne_59311_D25.xls? Could it be special characters like spaces in the filename corrupt the results?

2 Answers 2


You can search with a '*' to ensure you get all results, for example:

the 413208mg_shake%20software_re%20po#%603.xls search can be returned via 413208mg or 413208*

Point of reference, it seems * can only be used at the end of a search term.

  • Thanks, @per and @zork! Makes sense but I thought I'd tried an asterisk in my testing to no avail. Tried it now and it does work using a test tool so I'll add it to my code.
    – Toadmyster
    Commented Apr 2, 2012 at 23:07

FileOne_59311_D25.xls has the word 59311 in the filename

413208mg_shake%20software_re%20po#%603.xls doesn't have the word 413208 in it (it has the word 413208mg, but that's not the same). It seems that it has 413122 somewhere in the content.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.