I have a document library with custom columns that point to metadata term groups.

When I add a file, the system sends an alert, at that time(when you upload the file), the system does not ask for the metadata columns yet, so the alert is sent with those fields blank.

If I checkin, and then edit properties, the alert is sent with all fields filled in.

Is this OOTB behavior? is there a way to make the alert work when the file is checked in?

1 Answer 1


Yes, this is the OOTB behaviour in SharePoint.

When you add or upload a file initially, without the meta data properties, the file is actually added into the SharePoint Library and your alert is fired automatically. While uploading a file, its a two way process, first you upload the file (here probably the alert gets fired) and then adding in the properties which is just editing the added file.

Adding in the properties while uploading or adding will be treated as editing the file and the next alert will be sent with filled in metadata property values.

To mitigate this behaviour, I would advise you to send an email alert only after checking a meta data field value. This could be achieved by using SharePoint designer workflows. Its pretty simple and you can configure to send email alerts, only when some fields or a combination of them are not blank.

  • what about the option on the library: Require documents to be checked out before they can be edited. I have noticed some different behavior when its set to Yes, the alert is only sent after the item is checked in, The alert does not arrive as an Item added, but item changed tho Commented Mar 27, 2012 at 8:08
  • When "Require documents to be checked out before they can be edited?" is set to Yes, alerts that are set to send on New Items are not sent. They are only sent for Changed Items with alert set when documents are changed. When set to No, alerts are always sent on New Items. Check this answer for more info - sharepoint.stackexchange.com/questions/26186/…
    – Deepu Nair
    Commented Mar 27, 2012 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.