1. I add a new property "Languages" to user profiles. This is a managed metadata property (type String (Multi Value))

  2. Users select 2-3 languages they speak

  3. In people search results I want to display the spoken languages along with other default info (Name, Job title etc.). I modify the people search core results webpart xsl accordingly so that languages information is included.

  4. On searching the language field is included but only the first chosen language shows up in the person's details card. If a user speaks more than 1 language only the first one is displayed.

More information:

  1. When I configure the XSL to display all properties (see http://msdn.microsoft.com/en-us/library/ms546985.aspx) the following relevant info is returned:

      <hithighlightedsummary>IT <ddd /> PolishPortugueseEnglish <ddd /No</hithighlightedsummary>

As seen in the above example (I'm searching for a user who speaks Polish, Portuguese and english) using the troubleshooting string returns "Polish" as value for the language parameter (partial info). However, the highlightedsummary field displays the full information - there are actually 3 values (Polish, Portuguese, English).

  1. Even though only the first value displays for a user search refinements show all the values

I initially spent lots of time thinking the XSL in my people results web part is to blame. However, it doesn't seem to be the case - the search returns only the first option for the language parameter before the result is transformed via the XSL.

Any idea if it's possible to display all values for a multi-valued managed metadata property in the user search result?

Thanks in advance, Greg

1 Answer 1


I recall that we had a similar issue with one of our fields and we were able to solve our problem by making sure the Managed MetaData Property - Has Multiple Values - was checked. You can check the value of your property has in Search Administration / Metadata Properties section.

  • That was it! Thanks so much, I spent so much time trying to get that to work!
    – Greg O
    Commented Mar 28, 2012 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.