I am using custom InfoPath task form in my project. All works fine, but I can't add new one. When I add it and click on task associated with it I get error: "The specified form cannot be found". After it I tryed using first working task form, save it with another name, change it FormURN to new, add it to my Forms module, but it doesn't work too. When after it I saved it with the first used name and changed FormURN back it works fine again. I can't understand why it happens. May be I have to clear cache or something else? Yesterday I encountered with similar problem, for which I found work-around, but now I haven't any ideas.

When it doesn't work:


<File Path="Forms\ApprovalFormNew.xsn" Url="Forms/ApprovalFormNew.xsn" />


<ProjectItemFile Source="ApprovalFormNew.xsn" Target="Forms\" Type="ElementFile" />



When it works in shown above places there are ApprovalForm instead of ApprovalFormNew.


<Property Key="RegisterForms" Value="Forms\*.xsn"/>

Is there a way to see more detail information about this error? There is no details about it in logs.

What I've tryed: IISReset, clear IE cache, reboot.

Any help is very appreciated.

PS: Sorry for my writing, English is not my native language.

PPS: Also I can't use default (not InfoPath view) for Tasks when I don't change default TaskType. Is it normal and I have to use either default view or InfoPath views, but not both?

  • Do you specify TaskProperties.TaskType for your every task? Mar 12, 2012 at 7:35
  • Thank you for your answer. Yes I do. I've solved the problem!
    – MikhailSP
    Mar 12, 2012 at 11:57

1 Answer 1


I've solved it, problem was not in caching. When I changed name of my form and republished it, I've missed to clear public URL in InfoPath Publishing Wizard. I've cleared it, and now it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.