0

I have a solution which is working well inside our Dev environment, then i created a PROD environment, and i defined a security group for the PROD environment + i grant the users Basic User security role inside the PROD environment. Now inside our power apps canvas application which is connected to SharePoint, we have a button that call a power automate flow using the Run() function, but when the user with the Basic User role inside the prod environment click on the button to call the flow, the user will get this error :-

PowerAppV2->Createitem,Condition.Run failed: {"error":{"code":"0x80048306","message":"Principal with id 144d1db1-3f0e-ef11-9f89-6045bd6a0f44 does not have ReadAccess right(s) for record with id a8a8227e-380e-ef11-9f8a-6045bd15b5b7 of entity workflow. Details: {"CallerPrincipal":{"PrincipalId":"144d1db1-3f0e-ef11-9f89-6045bd6a0f44","Type":8,"IsUserPrincipal":true},"OwnerPrincipal":{"PrincipalId":"d7ddef55-9d09-ef11-9f8a-6045bd151a18","Type":8,"IsUserPrincipal":true},"ObjectId...

any advice?

3
  • how does this question relate to Sharepoint?
    – teylyn
    Commented May 10 at 0:29
  • @teylyn the power apps and power automate flows inside the solution is connected to sharepoint.. and there is already tags for the topic i am asking about !!1 Commented May 10 at 0:30
  • Yeah, but SharePoint does not do "environments"
    – teylyn
    Commented May 10 at 0:39

1 Answer 1

0

"Power apps v2" connector provides an option to run the flow with "run only users". Click on your flow, on the bottom right you will have an option to add run only users, add the users/ groups and select the connection used and click on save.

Refer below link for more details https://www.youtube.com/watch?v=76-yrWq6dQ8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.