0

We have changed password for SharePoint 2016 Farm Admin credentials. -Changed in AD; Updated using PowerShell in SharePoint server

  • Set-SPManagedAccount - UseExistingPassword -Identity DOMAINA\SPSAdmin -Prompt for the password and entered the updated password -Repair-SPManagedAccountDeployment -IISRESET

Unable to change SharePoint account password in SharePoint 2010

After that, Central admin is not opening. Throwing error Server Error in '/' Application.

Steps we did: -Changed back to old password from AD. -Changed password from IIS App Pool -Run Config wizard - Not running as it is not able to connect to configuration database

Looks like password change is not reflected properly.

Can anyone have any idea how to proceed?

Any help is highly appreciated.

Edit: Getting below error when opening SharePoint Management Shell:

The local farm is not accessible. Cmdlets with FeatureDependencyId are not registered. You cannot call a method on a null-valued expression. At C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\CONFIG\POWERSHELL\Registration\SharePoint.ps1:10 char:1

  • $adminWebApp.GetEndOfSupportMessage($false, [ref]$endOfSupportSeverit ...
  •   + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
      + FullyQualifiedErrorId : InvokeMethodOnNull
    
    

You cannot call a method on a null-valued expression. At C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\CONFIG\POWERSHELL\Registration\SharePoint.ps1:13 char:1

  • $adminWebApp.GetEndOfSupportSeverityLevelData($endOfSupportSeverityLe ...
  •   + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
      + FullyQualifiedErrorId : InvokeMethodOnNull
    

1 Answer 1

0

In the script you ran it does not look as you are actually updating the farm with the new (nor old password) after changing it in your AD.

Try this instead (as an admin) to update your farm with the new farm account password.

$FarmAccount = "DOMAINA\SPSAdmin"
$Password = "farmAccountPassword" -AsSecureString
Set-SPManagedAccount -Identity $FarmAccount -ExistingPassword $Password -UseExistingPassword $true
10
  • Thanks for the reply: Got below error:Set-SPManagedAccount : Cannot access the local farm. Verify that the local farm is properly configured, currently available, and that you have the appropriate permissions to access the database before trying again. At line:1 char:1 + Set-SPManagedAccount -Identity $FarmAccount -ExistingPassword $Passwo ... + + CategoryInfo : InvalidData: (Microsoft.Share...tManagedAccount:SPCmdletSetManagedAccount) [Set-SPManage dAccount], SPCmdletException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletSetManagedAccount
    – Sjk
    Commented Apr 19 at 7:12
  • Also, modified the script; Above was getting error:$Password = ConvertTo-SecureString -String "password" -AsPlainText -Force Set-SPManagedAccount -Identity $FarmAccount -ExistingPassword $Password -UseExistingPassword:$true
    – Sjk
    Commented Apr 19 at 7:14
  • Were you trying to set the old password that you switched back to? Did you change it back in IIS were you changed it (changing it in IIS should not been necessary). If you check the Services on the server hosting central administration - are the services related to SharePoint stopped? Try to change the password there manually for the services related to the farm account to the current one and then start them if they're stopped. Commented Apr 19 at 7:27
  • Regarding the error message you see in PowerShell: sharepointdiary.com/2014/07/… Commented Apr 19 at 7:28
  • After the issue started. I have reset with old password in AD. But issue not resolved. Tried changing in IIS too. Also services updated manually. Now Central Admin app pool is getting stopped continuously. Local farm issue started after changing password only, before that it worked
    – Sjk
    Commented Apr 19 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.