1

We're attempting to migrate from SharePoint 2013 on-premise to SharePoint Online, but encountered an error related the SharePoint SOAP endpoint listed below:

WebPartPagesWebService.GetWebPartPage(String documentName, SPWebServiceBehavior behavior)

In an attempt to verify that the issue is in fact on the server and related to SharePoint we tried to simply call the endpoint through PowerShell for a specific page:


# Variables
$WebSvcUrl = "" # Example: https://domain.dk/_vti_bin/WebPartPages.asmx
$PageRelativeUrl = "" # Example: sider/default.aspx
 
# Create webservice proxy
$webserviceProxy = New-WebServiceProxy -Uri $WebSvcUrl -UseDefaultCredential
 
# Get namespace and spwebservicebehavior
$autoGeneratedNamespace = $webserviceProxy.GetType().namespace
$SPWebServiceBehavior = New-Object ($autoGeneratedNamespace + ".SPwebServiceBehavior")
 
# Call endpoint
$webserviceProxy.getWebPartPage($pageRelativeUrl, $SPWebServiceBehavior)

But we encounter the following error:


Exception calling "GetWebPartPage" with "2" argument(s): "Server was unable to process request. ---> Kan ikke fuldføre denne handling.
Prøv igen. ---> Kan ikke fuldføre denne handling.
Prøv igen."
At line:1 char:1
+ $client.getWebPartPage("/Sider/default.aspx", [Microsoft.PowerShell.C ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : SoapException

Update 1

We attempted to run the same script in another SharePoint environment without any issues, so right now we're working with the theory that it's related to the current SharePoint CU and that they need to upgrade the SharePoint farm.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.