We have a server farm that is having issues deploying WSPs. The odd thing is that the server goes through all the motions of deploying the WSPs with no errors. That is, the job is scheduled appropriately. I can see the status change on the Solution Management page from deploying to deployed. There are no errors in the trace logs or event viewers. However, the 12 hive only contains files that existed prior to the upgrade. This is also the case in a retract,delete,add,deploy scenario.

Note: Our server topology has changed over time. Our Central Admin machine reached its End of Life, so we added another server to the farm, moved the central admin with the stsadm tool, and removed the old server from the farm.

Here is what I have tried:

  • Deployed to two other farms: successfully deployed new files (rules out WSP as the problem).
  • Restarted OWS Timers on both WFE
  • Restarted both Machines
  • Verbose Logging
    • The one difference here is that on the server farms that work, you see individual files being deployed. On the server farm that doesn't work, the logs show that the system checks to see if it is deployed and that is it.
  • Ran preupgradecheck to check on server farm health with no errors
  • Checked the databases (namely config) to see if there are quota/growth/space issues. There were no errors.

What else can I check? Typically, we can use the errors in the logs as a basis for research, but without something to go on, I'm striking out.

UPDATE: I tried two more debugging steps that might be helpful in the future but did not produce results in this case:

  • Retract, Delete, Add, Deploy Solution - left with the same files as I started
  • Run ProcessMon while upgrading the solution - I could see where the cab was unpacked in the temp directory, then promptly deleted.

Finally, we were lucky enough to still have the soon to be decommisioned server that previously ran Central Admin (Server1). So, I added the server to the farm. Removed the Central Admin from the new Server (Server2). Added it to the old server (Server1). Deployed the WSP. On the Solution Management page, two of the three front ends deployed successfully (Server1+Server3). I ended up having to remove and re-add Server2 from the farm. Then move the CA back and remove Server1 from the farm.

All is now well.

  • @MBSurf: It would be great if you could move your solution into answer. Otherwise the system will forever think it is unanswered!
    – Alex Angas
    Commented Jun 15, 2010 at 23:35

2 Answers 2


Have you tried removing the files in the hive and redeploying the wsp? Just to make sure nothing is wrong with the files themselves.

Do you get any warning in central admin that your frontends are not in sync?

  • I re-ran the deployment using ProcessMon and did not see any attempts (failed or otherwise) to write to any directories in the 12 hive.
    – MBSurf
    Commented Jun 1, 2010 at 17:19
  • Judging from the updated question (with the answer) his WFE or Central Admin servers were out of sync, so I think this is a good answer.
    – SPDoctor
    Commented Jul 27, 2011 at 8:14

To roll the dice...

Are you able to deploy any WSPs at all now?

Alternatively, can you manually install a feature without wrapping it in a WSP?

  • No, I was not able to install any WSPs at the time.
    – MBSurf
    Commented Jun 1, 2010 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.