After i installed windows update on my wss 3.0 crashed. It gives me page with "Cannot Connect to Configuration Database" in central admin as well as web app. I tried to run SharePoint Products and Technologies configuration wizard. It gave me enter image description here

Then i Tried to take back up of the Web appp just incase, it gave me this error:enter image description here

After that, i checked my content database it was only 28 MB from 450 MB. Looks like content DB is also corrupted.I tried diffrent stuff in google, but nothing seems to work. Please Help!!!!!!!!!!!

1 Answer 1


Usually I find this kind of problem is due to SQL Server not running or inaccessible (e.g. firewall rules are blocking access, authentication problems, etc. etc.). Look at your event logs to see if there are SQL authentication failures. You may need to temporarily open up permissions on your database and perhaps lock them down again later once you have things working.

Of course it may be that you have lost SQL Server and/or your databases. Do you have backups? It isn't much use trying to do anything from stsadm at this stage.

You will need to work at the database level to get your content and possibly config databases back online and accessible to SharePoint. Then you can start looking at recovering your SharePoint environment.

  • 1
    There are some important things to check in this post. Like SPDr. said, make sure one of these updates did not set the SQL Server's firewall or config to where it cannot be accessed. But it might all come down to having SQL Server level backups... Commented Mar 10, 2012 at 15:03
  • Thank You for your responce. I went in and checked firewall, it was working fine. I also turned it off and tried it, no results. About opening up permissions to database i am logged in as local admin with all permissions. Do i need to do anything else? Unfortunately i dont have updated backup of the database. Are there any other way to recover the data and get site back live? Thank You Commented Mar 12, 2012 at 2:16
  • Your farm account needs db_owner permissions on your SharePoint databases - see technet.microsoft.com/en-us/library/cc678863.aspx for more detail. If your config database is gone you can reconfigure your farm without too much work. If your content database is corrupted you may be able to recover it at the database or OS level (if you can't mount it in SQL Server) or possibly using stsadm -o databaserepair if the data is still there but you can't attach it to SharePoint (obviously, backup what you have first). If content database is gone and you have no backup you are pretty much hosed.
    – SPDoctor
    Commented Mar 12, 2012 at 13:30
  • Hello SPDoctor, I went to sql studio content db is still there. I can expand the tree and see all the columns,but when i query the tables it gives me the "Access to table xyz is blocked, because signature is not valid". Does that concludes it is corrupted? Commented Mar 13, 2012 at 13:18
  • Sorry, you will need to ask a SQL Server doctor ;-)
    – SPDoctor
    Commented Mar 13, 2012 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.