0

My company uses Sharepoint Online. I have a site on that SharePoint that uses the modern experience.

It's a "communication" site, if that changes anything. In the site content -> site pages (i.e. a SharePoint list) I added a column named "MyMetaDataColumn" and I want to use this column value as a filter in some web parts e.g. in the highlighted content web part.

As I understand, I therefore need to find the "crawled metadata" version of that column i.e. named "ows_MyMetaDataColumn" in the "search schema" of SharePoint to then map this to a managed property that I can then use to perform filtering.

I do not see this crawled metadata. I tried re-indexing the list. I tried re-indexing the site. No changes.

What am I missing? Which setting could prevent the column to be crawled and usable as I intend to ?

4
  • Do you have some data using the term? Has a full crawl been executed? Commented Mar 21 at 19:57
  • As suggested by @DerekGusoff, add some data in this new column for few site pages and try manually re-indexing site pages library again. Wait for 1-2 hours until crawl is completed properly. Let me know if this works for you. Commented Mar 22 at 5:41
  • How can I know (I am not admin and don't have access to that) when it has been crawled? Commented Mar 22 at 7:37
  • And yes, I have pages using this column with different values Commented Mar 22 at 7:57

1 Answer 1

0

For people facing the same issue.

In my case, the problem was the type of column. When I created the column I chose "choice" thinking it would be crawled anyway independently of the type given this article providing the naming conventions for practically all types.

I changed the type of column to "metadata" and then it appears with the prefix ows_taxId.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.