0

I created a SharePoint library and added two columns to it: one column is of the image type, and the other is of the number type.

Now, I want to include both of these columns in the content type.

2
  • How many content types you have in the library? I which content type you want to add those columns? Commented Mar 12 at 12:14
  • I added only one content type to my library
    – Renuka
    Commented Mar 13 at 8:02

1 Answer 1

1

Ideally, when you create a new column in the document library, you should select Add to all content types to "Yes" which adds the new column to all the content types available inside the document library:

enter image description here

If you have not selected it, I think SharePoint should add the new column to default content type (not sure about other content types). If column is not added to content types in document library - you can follow below steps to add the library columns to document library content types:

  1. Go to library settings page

  2. Click on Advanced settings link

  3. Set Allow management of content types? to Yes

  4. Click OK button at the bottom of "Advanced Settings" page to save the changes

  5. From library settings page, click on your content type name where you want to add the column under Content Types section

  6. Click on Add from existing site or list columns link from content type page

  7. Select List Columns in the top drop down, select column you want to add from left side box and click Add button:

    enter image description here

  8. Click OK button at the bottom of page to save the changes

This should add the newly created column in the content type inside SharePoint document library.

2
  • i completed the above process and added both columns in content type but when I added these data in document, only number type column is visible in quick parts > document property.
    – Renuka
    Commented Mar 13 at 8:07
  • I think Image column is not supported in document quick parts. Commented Mar 13 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.