0

I have a list "Staff Contact Information" which is assigned to a user group. I want user to see or edit the item only they were created. So I setup the Item-level Permission to "Read Items that were created" and " Create items and edit items that were created by user". Also, I setup the List Permissions to "Contribute" but users are not able to see any items they created. When they open the list there is no item to show.

Any ideas why list is behaving like that? Thanks, Asif

1 Answer 1

0

Here are somethings to take note of:

  1. Item Level Permissions are not available for Document Libraries and Issue Trackers, make sure your list is not of these types.

  2. Item Level Permissions are only available if their permission level at the site and list is at least "Design"

  3. Item Level Permissions settings are only visible to site owners.

2
  • Thanks Martin for the guidance. My list is custom and not the Document Libraries or Issue Trackers. I set the Permission to "Design". I'm the owner of the site. Would you assist how to set the Design permission level at site? I can see the different permission levels (Full, design, edit etc) under Site Permission >> Advanced Permission Settings>>Permission Levels but not sure how to setup any permission to the site.
    – Asif Karim
    Feb 22 at 14:43
  • Please refer to this document and youtube link: global-sharepoint.com/sharepoint/… And: youtube.com/watch?v=HZmZIQL-Yd0 Feb 26 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.