0

I've done some investigating and if I use "Share" -> "People with existing access" it does not create unique permissions.

However, if the user clicks on "Copy Link", it automatically creates a link using our default ("People in our organization"), before I am able to change the setting to "People with existing access". This is what is creating all of the random unique permissions.

Do anyone know if there is a way to prevent a file from getting a unique permission if the users want to copy the link?

1
  • Copy file URL by following this instead of "Copy link" option. Let me know if it works for you. Feb 6 at 3:12

1 Answer 1

1

I don't think you will be able to change the SharePoint default functionality of "Copy link" option in the document library.

If you want a direct link to SharePoint file to share with users who are already having permissions on the file, follow below steps to get the file URL:

  1. Go to the document library/folder where your file is uploaded.
  2. Select the file and click on Open the details pane (i icon) from command bar (top right side)
  3. Copy direct link using the copy icon highlighted in below image:

enter image description here

You may need to append ?Web=1 to open file in web browser before sharing it with other users, like:

https://contoso.sharepoint.com/sites/MySite/MyLibrary/MyDocument.docx?Web=1

Additionally, you can hide the "Copy link" option from library command bar using SharePoint JSON view formatting:

{
  "commandBarProps": {
    "commands": [
      {
        "key": "copyLink",
        "hide": true
      }
    ]
  }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.