Microsoft List is the evolved version of SharePoint List. I am working with Microsoft List before ever touching SharePoint List. So I do not know what features are carried over from the SharePoint version.

There is an default ID column which comes with a List. As I understand, it auto-increments as the user adds a new row to the List.

I decided to make this column visible to show in the List. I did this so that this ID can be used as the primary key value that can be used when a user wants to modify or look up an item in the List.

But I found that when the user clicks to add a new item, the ID field appears for the user to add an ID. This is not good. Not only was I able to add an id that is way out of sequence, but I was able to create a record with an id that had already been assigned.

In an attempt to fix the problem, I set the ID to HIDDEN mode. But then, fir some reason, when I clicked to add a new item, the ID appeared for the user to enter an ID for that field.


I got a response to this issue from spiceworks and I will paraphrase the response and what I was suggested to do.

In Microsoft Lists, the ID column is a system field that automatically increments for each new item added. It is intended to be read-only and not directly editable by users. However, if the ID field is showing as editable when adding a new item, then it might be due to custom form customization or a glitch in the list settings.

To ensure the ID column remains un-editable, I followed these general steps:

  1. Go to the List Settings by clicking on the gear icon in the top-right corner of the list page.
  2. Under the Columns section, click on the ID column to view its settings.
  3. If there's an option to make it read-only, ensure that is selected. (Typically, one cannot change the settings of the ID column as it's system-managed.)
  4. If you've previously modified the form using Power Apps or any other custom form editor, revert those changes or edit the form again to make the ID field read-only.

If unable to change the ID field to read-only using List Settings, consider using Power Apps to customize the form:

  1. Navigate to the list and select "Integrate" from the top menu.
  2. Choose "Power Apps" followed by "Customize forms". In Power Apps, select the ID text input control.
  3. Set its "DisplayMode" property to DisplayMode.View to make it read-only.
  4. Save and publish your form changes.

Please note that direct modification of system fields like ID is not recommended and generally not possible through the standard list interface. If the ID field remains editable after these steps, it might be a temporary issue with Microsoft Lists, and you may need to contact Microsoft Support for further assistance.

I followed all 8 of the steps listed above, as best as possible and now I know what is wrong now but I do not know how to fix it.

So, starting at the beginning, the List/Grid view of the List shows a column titled "ID"


I clicked to show the settings but here is part of the problem. There is nothing in on the settings panel to denote the column, ID. It is simply not there at all.


Now, the problem finally comes to light when I click on the List Integrate -> Power Apps -> Customize forms


Do you see it? It calls the ID column, "Title". There is some sort of confusion between the ID field and the Title field. Since ID does not appear on the setting page, it has been somehow removed (it is a system level column name that, I am guessing, is not to be deleted -- I would think it should be impossible to delete, but it is still gone). So the ID I am using is a false ID, it is just a renamed Title column. Somehow Power APP knows this and calls it "Title". So this is a mess that I would like advice on how to untangle.

I am thinking to rename my ID to "Title" and then find some magic way to bring the ID back. This part is out of my proverbial wheel house. And I am looking for advice.

1 Answer 1


First of all, SharePoint default ID column is not editable from list forms and it should work as you expected.

By looking at the images you shared, I think you have renamed the "Title" column to "ID" previously (changing display name of the Title column from "modern" list view). See the Abc type against "ID" column in the list form - by default ID is an Number type column and it should not have that Abc icon which is generally used for text columns (like "Title").

Ideally it should throw error like this while renaming Title column to ID. But maybe there is a space or some extra character in the name which allowed renaming:

You can follow these steps to check how many "ID" columns you see in show columns popup:

  1. Go to your SharePoint list

  2. Click on Add column and select Show or hide columns:

    enter image description here

  3. If you see 2 ID columns on the popup, it confirms my assumption:

    enter image description here

  4. Check the checkbox against both the ID columns and click "Apply" to save the changes

Then you can rename your another (editable) ID column back to "Title".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.