0

I am stuck with a problem.

I have created a new document library in a sharepoint. There I have entered some metadata for all the files in the entire library according to my wishes and created corresponding columns.

I have also specified the desired columns in the "All documents" view. Now I would like to add some document sets to the document library. In addition to the columns that I use in the document library, I would like to insert and display a few additional columns in each document set. Is there a way to display the additional columns in the respective document sets while keeping the "All Documents" view (and to display the original columns again when "jumping back" to the document library)?

I would be so grateful for any help and advice.

PS: I have used document sets instead of folders because I have read in many places on the Internet that they actually only have advantages over folders. So if my requirement could be realised using folders instead of document sets, that would be fine with me!

Thank you so much in advance!

1 Answer 1

1

See: https://www.c-sharpcorner.com/blogs/document-sets-in-modern-sharepoint-libraries

And: How to set different columns for document set than the files within it?

  • To add more columns to the document set, go to Document Set Settings, and there you can select more columns.

  • Create a custom content type and add that into the document set settings the content type that you created.

  • Go into your document library’s advanced settings and turn on Allow Management of Content Types.

  • Now you can modify the "All Documents" view to include the columns you want.

Try this and let me know if it helps.

1
  • Hi Martin, thanks a lot for the prompt response. I managed to do it partially. What i managed to do: In Addition to the content type "document" I added a content type "01 document". In that content type I added the additional column that I would like to display and also added it in my document set. That works. But: When editing the view “All Documents” the column is still displayed in both the library and the document set. How can I achieve that it is only displayed in the document set? Here a Screenshot to visualize what I mean: i.ibb.co/GttTXWB/Screenshot.png
    – Michel S
    Jan 13 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.