0

Background: I have two server 2016 farm. one if Web frontend with Distribution cache and the other server role is Application with Search. I have installed search service application on App server using PowerShell commands. PowerShell is successful.

But when I go back to "Service on Server" page, I don't see SharePoint server search service at all. I don't see anything related to search there. But these services shows up under Server in his farm section. Not sure if this is due to SP not installed properly or I need to start from scratch.

Also when I select Search service application under service application dashboard, search administration throws an error "remote server 503". but all the remaining components looks active.

I am scratching my head about these two issues. I tried all the recommended steps from internet and no luck

Tried IISreset stopped and started timer server ran enable-sptimer job re-ran SharePoint configuration wizard

Important one: I don't see Searchadmin.svc and serachservice.svc under ISS websites. Somehow they are missing

1 Answer 1

0

SharePoint Search Service not showing under services on server

  • Check the services console on your Windows server itself, not on the Central Administration of SharePoint. If the service is there, check if it is started or not. If it has started, try setting up a different account and then start the service.

Error "remote server 503" when selecting Search service application

  • This means that the IIS Application Pool hosting the Search Admin has failed. Look at the Application and System Event Logs on the server. Central Administration -> Application Management -> Manage service applications, select your search service application, then click Properties, then find all related application pools name. Then you can use Get-SPServiceApplicationPool | select Id, Name to list all application pools and find search related application pool ids. Then go to IIS Manager -> Application Pools, then find the related search application pools based on IDs that you find in the above, make sure they are started. If they are stopped, start them.

Missing Searchadmin.svc and serachservice.svc under ISS websites

  • Try changing the application pool to use SharePoint Web Services System for search service applications. Go to IIS -> Expand server -> Expand sites -> Expand "SharePoint Web Services". Check all the GUID 1 by 1 in content view until you find searchadmin.svc and searchservice.svc. Right click GUID go to advanced settings. Change the application to "SharePoint Web Services".

Let me know if any of these options help.

4
  • Thanks for your reply. When I expand SP web services system in IIS, I see two GUID belongs to Search, but when I click on explore button, it throws an error saying "Th system cannot find the file specified" And all App Pools are working fine. I did restarted several times , but still same issue Jan 9 at 21:07
  • Try enabling the timer job and reset IIS: Enable-SPTimerJob job-application-server-admin-service Net Stop sptimerv4 Net start sptimerv4 iisreset sharepoint.stackexchange.com/questions/169793/… Jan 9 at 21:23
  • Still same error. I did followed above mentioned article. I am guessing folder that saves searchservice.svc might have been deleted and need to find where it and to restore that. may that wil solve the link bewtween IIS GUID and explorer folder? Jan 9 at 21:42
  • Yes unfortunately that seems to be the only solution sounds like the files are corrupted you need to repair them. Jan 9 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.