0

I have multiple lists and libraries that take advantage of Information Management Policy settings, and they all work fine. This is SharePoint 2016 on premise. The jobs run over the weekend only. I have one specific list that doesn't fire at all. There's no history and the entries do not purge. If I run the workflow manually, it works fine. Is there any setting on a given site or site collection that would overrule the policy? I have also tried simply sending to the recycle bin, rather than running a workflow. This doesn't fire either. I copied the list to another site collection and the exact same data deletes fine. I checked that the content type is item and the policy is set as such. I am closing in on the list view threshold. Any ideas are welcome.

Thank you!

1 Answer 1

0

Have you tried any of the following?

  • Ensure that the "Library and Folder Based Retention" feature is activated. Go to "Top level site settings" -> "Under Site Collection Administration" -> "Site Collection policies” -> Activate "Library and Folder Based Retention".

  • By default, the "Information management policy" and "Expiration policy" will work "Weekly". Try changing it to "Daily" in Central Admin -> Monitoring -> Review job definitions -> Find "Information management policy" and "Expiration policy". You can also force the timer job to run by going to the Timer Job Definition for the Expiration Policy and selecting "Run Now".

  • Check that the retention settings are set for "Content Types", not "Library and Folders". You can find this option in "List Settings" -> "Information management and policy settings" -> Find the "Change Source" link.

5
  • Thank you for your feedback. Library and Folder Based Retention is active. I am not allowed to change the frequency (management decision). I am running the policy on the item content type. "Source of retention for this list: Content Types". Both my test list and my problem list are set up the same (as far as I can tell). Thank you!
    – Sean
    Commented Jan 8 at 20:32
  • Hi Sean, The retention policy might not apply to existing items in a list. If this is the case, you might need to reapply the policy to these items. Can you investigate if there are unique permissions that might be interfering with the policy? Check if there are any custom settings or workflows associated with this list, they could potentially be causing the issue. If the list has a large number of items, it might be hitting the threshold limit, which could interfere with the policy. Commented Jan 8 at 20:38
  • I will try that. Thank you very much! I will let you know if I find anything out.
    – Sean
    Commented Jan 8 at 22:45
  • Just a quick note: The site collection admin personnel was not the same (the only one I am not in). I made sure to add myself since I created the policy. I recreated it to be sure. I will try to run manually from CA tomorrow. Thanks again!
    – Sean
    Commented Jan 8 at 23:03
  • Just a note. This still has not worked. Baffling. I may just move on to delete 1K at a time using content and structure.
    – Sean
    Commented Jan 16 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.