I've completed an installation of a single server SP2019 farm with AD, DHCP & DNS.

Central Admin loads perfectly fine and I can create new Content DB's and Site Collections.

I've correctly configured the registry here:


and here:


I'm connected to the server via RDP, however I can't load any sites that I've created. When I browse to any sites (including the default root site) I get the IIS splash screen:

enter image description here

Here are my IIS bindings:

enter image description here

I've setup these single server farms many times in the great before and I remember there were a few caveats about loading sites on the single server instance.

Is there anything else I'm missing?

3 Answers 3


You can check these:

  • In IIS, stop the Default Web Site

  • Check the bindings URL of the site corresponding to your SharePoint web application

  • Check the alternate access mapping in the Central Administration (System Settings > Configure alternate access mappings)

  • If you use custom DNS, you can edit the host file (C:\Windows\System32\drivers\etc\hosts) to add something like that: my-new-webapp.dev.local

  • Thanks for responding! None of these steps worked for me. I've edited the post to include my IIS bindings.
    – neptr
    Commented Dec 19, 2023 at 17:56
  • But where is your web application? I don’t see it in IIS. This is not the default web site. What about your host name and AAM?
    – jleture
    Commented Dec 19, 2023 at 18:31

It looks like you haven't created any Web Application in Central Admin.

It is better to change Default Web Site http binding from port 80 to smth else (like 8888) and leave it enabled.

Then you should create the Web Application and you'll be fine.


The issue was caused by a lack of disk space and memory on the VM. This played havoc with the setup process.

Initially during the SharePoint/SQL installation I had only 30gb of disk space and 4gb RAM.

I created a new VM with adequate storage and memory and started from scratch. Everything now works perfectly!

  • Not the most obvious reason )
    – lehuspohus
    Commented Dec 20, 2023 at 16:02
  • No that's what had me scratching my head. But i suppose it's documented now so...
    – neptr
    Commented Dec 20, 2023 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.