I've run a site collection backup using Backup-SPSite. I then deleted the Site Collection using CA. Then tried to restore is using Restore-SPSite. Got the error "No content databases are available for this operation but the site collection is scheduled for deletion in at least one content database. Either wait for the deletion operation to complete or create a content database, and then try the operation again. To create a content database, click "Content databases" on the Application Management page, select the Web application to use, and then click "Add a content database".

I then ran the Gradual Delete Timer Job manually but I'm still getting the error.

Any suggestions? As usual, thanks a million in advance!

3 Answers 3


I have also faced the same issue even after running the Gradual Site Delete timer job and Remove-SPDeletedSite command

It worked only after adding the DatabaseServer and DatabaseName (to an existing DB) parameters. Please ensure the database server name is correct if there are aliases. You can pick it from "cliconfg" from Windows->Run or from by clicking on existing database name in CA.

Restore-SPSite 'site collection url here' -Path C:\Backup\site_name.bak -Force -DatabaseServer "server name here" -DatabaseName "db name here"

Try to run the gradual site delete timer job with the option "Run Now". If that does not work, from services.msc try to restart SharePoint Timer Job Service. Once the timer is restarted , try running the job once again.

If that does not work , try looking into the discussion from here PowerShell - Restore-SPSite Error

  • Thanks however same results unfortunately. I had seen that thread but it was inactive & unresolved (last post October 2011) so I thought I'd start another. I noticed the timer job is executed. Status "succeeded" but duration is 00:00:00 which is suspicious.
    – user4747
    Commented Mar 7, 2012 at 19:30

After deleting the Site Collection through CA, I tried a 'Run Now' on the Gradual Site Delete timer job but still got the same error on the restore. The command 'Get-SPDeletedSite' showed me the site hadn't been completely deleted. Then 'Remove-SPDeletedSite' got rid of it. Then I was able to do the restore.

In the end, this is what worked for me as the cleanest/fastest procedure:

Backup-SPSite –Identity http://sharepoint.abc.com/sites/testsite -Path “c:\site collection backups\testsite.bak”

Remove-SPSite –Identity http://sharepoint.abc.com/sites/testsite

Restore-SPSite –Identity http://sharepoint.abc.com/sites/testsite2 -Path “c:\site collection backups\testsite.bak”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.