0

'm currently experiencing an issue with the News Search web part in SharePoint Online, and it's throwing a 400 error. The web part utilizes a query instead of search. While inspecting the browser dev tools, I noticed a query being sent to the Site Pages library, structured like this:

https://mytenant.sharepoint.com/sites/team1/_api/sitepages/pages/feed?promotedstate=2&published=true&$expand=CreatedBy,FirstPublishedRelativeTime

enter image description here

Upon closer examination, it seems that the query is expanding the "CreatedBy" field. However, in SharePoint list/library, there isn't an internal field named "CreatedBy." We do have a field named "Author," which serves as the CreatedBy label. Has there been any recent changes causing this discrepancy? Any insights on what might be the root cause of this issue would be greatly appreciated. Thanks!

2 Answers 2

0

First, each library or list creates a column "createdBy" by default, which is not displayed in the default view. You can check to see if the column exists. Please navigate to your library or list and click on the gear icon in the upper right corner > List Settings> Advanced Settings. Under Columns you can see if the CreatedBy column exists. enter image description here

Also, have you modified your crawl schema? Please navigate to SharePoint Administrator Center > More Features > Search >Manage search schema. Under Manage Properties find Authors, open the Edit page and slide it to the bottom. In the Mappings to crawled properties area look for ows_Created_x0020_By. If it is there, you can choose to remove it.

enter image description here

enter image description here

enter image description here

1
  • Since you are creating new column "CreatedBy", how do you plan to populate that created by column? Becuase the created by column you highlighted is an Author column
    – Vijay
    Nov 14, 2023 at 13:25
0

Just in case someone also have same problem, my list was contains more 12 Lookup/Managed Metadata column causing the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.