0

I created one Metadata column with multi-select and it created 2 hidden fields with suffixes "_0" and "_1", Due to that Sharepoint search is not working for this field   Can anyone guide me on why two hidden columns are created and how to fix the search issue in this scenario?

Edit: I have created this list using template option. using pnpjs, i am taking one site as reference and creating another site with site template approach. Created almost 26 sites and among 26, only two sites are having this issue.

1 Answer 1

0

Creating a managed metadata field will create an additional hidden field of type Note with a _0 suffix. This is by design. Not sure why there would be a second hidden field with a _1 suffix. Can you share the field setup?

I might be wrong, but I doubt that is the reason your search may not be working, how did you come to that conclusion? Have you done any search configuration to map crawled properties with managed properties?

3
  • I have edited the question. Since it is site column, managed property created automatically. I didn't changed anything to that. Anything to update in that section?
    – Mihir
    Commented Sep 25, 2023 at 9:14
  • Ok, so which part of search is not working? Automatically created managed properties are not refinable, sortable etc.
    – Paul Lucas
    Commented Sep 25, 2023 at 23:01
  • general search not working
    – Mihir
    Commented Sep 26, 2023 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.