Have created a SharePoint list and share it out with my business users, and so far have reported a few observations here: User reported that they are viewing the SharePoint list in classic experience instead of modern experience which I want them to be. Have changed the setting under List Settings - Advanced Settings to force the page to load in modern experience by default instead of system detect however it doesn't seem to resolve the issue User also reported that whatever item that they opened up and edit, it does not save the entry when they click on the Save button. There is a simple error message says "The server was unable to save the form at this time, please try again" - does not seem to be much helpful and have researched solutions online (including activating a user control module under site settings) but does not seem to resolve the issue as well

Wonder if this is caused by my permission settings? I have break away the permission settings for my list from my SharePoint site and have granted it to my user access solely on the list itself only.

Appreciate for all the inputs, thanks!

1 Answer 1


For the first question, check if the site collection feature "SharePoint Lists and Libraries experience" is activated. If it is activated, please turn it off to see if the problem is solved. enter image description here For the second question, it is unlikely to be caused by permission settings. The error message suggests that there may be an issue with the server. The user can try clearing their browser cache or using a different browser to see if that resolves the issue .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.